Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is there any way to make Mozilla Firefox automatically rename downloaded files of the same name like Chrome does?

  • 10 svar
  • 1 har dette problem
  • 44 visninger
  • Seneste svar af taseron

more options

When I right-click on an image in Chrome, and choose `save as`, it doesn't ask me for a new file name if a file with the same name exists in the folder. It just adds a `(1)` suffix to the filename automatically. However, in Firefox, it asks me to type a new file name if the directory contains a file with the same name. Is there any under-the-hood switch to fix this behavior? ( BTW my download option is set to "Save files to Downloads without asking me every time" ) Sounds like a simple problem but imagine you need to download 100 images from a web page and every file on the server is named `image.jpg`.

Ændret af taseron den

Alle svar (10)

more options

So you want it to append the number instead of asking you?

Nyttig?

more options

I think that Firefox should rename the file and automatically add a number when you haven't selected the 'ask' choice in "Options/Preferences -> General -> Downloads".

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Nyttig?

more options

I think the problem is using Save Image As... (or other Save something As... menu items) always shows the file browsing dialog and doesn't do any automatic name collision resolution for you. Maybe an add-on could provide an easier workflow.

Nyttig?

more options

@jscher2000 @cor-el

`Save Image As` dialog is the problem. It should be adding the (1) suffix to the file name but it doesn't.

You can simply test this on this page.

STEP 1) Just right click on your avatar image and select `Save Image As...`

STEP 2) Type ENTER and save it with it's original file name.

STEP 3) Repeat STEP 1

STEP 4) Type ENTER and it won't save. It will ask `File already exists. Do you want to replace it?`


If you do this with Chrome or Opera, it doesn't ask you to rename the file. It simply renames it by itself and all you need to do is press ENTER.

I think this is a more userfriendly way for this process.

I'm asking if this feature exist in Firefox and is it possible to activate it by some kind of `deep switch.` If not, I'd be glad to submit this as a requested feature to be implemented in the future Firefox.

Ændret af taseron den

Nyttig?

more options

One thing you could try is to right-click the download link and select Save As. Firefox only renames the files if you aren't using the "Ask" option in Options/Preferences and let Firefox save the files to the default download location.

Nyttig?

more options

I have reverse problem :) Recently, with firefox 79.0 it starts me add "(1)","(2)", etc to files instead simply overwriting them. Does anybody knows how to turn it off? I simply want to overwrite file. I have default download folder turned off.

Nyttig?

more options

Firefox never has has the choice to overwrite an existing file automatically. If you let Firefox save files automatically then you get a number appended. If you select the "Ask" choice then Firefox will ask confirmation for overwriting an existing file, but will never do this automatically. There might be an extension that has this overwrite feature, so maybe search the Add-ons website.

Nyttig?

more options

kjonca said

I have default download folder turned off.

Do you mean you set Firefox to always shows you a file browsing dialog so you can choose the destination folder to save in? (This screenshot is from the Options page:)

That dialog should not add (1), (2), etc.

Nyttig?

more options

AKASH kUMAR said

One thing you could try is to right-click the download link and select Save As. Firefox only renames the files if you aren't using the "Ask" option in Options/Preferences and let Firefox save the files to the default download location.

No, it's not related to the "ask" option. Please read my post above. It contains step-by-step instructions to reproduce the problem. Thanks anyways.

Nyttig?

more options

kjonca said

I have reverse problem :) Recently, with firefox 79.0 it starts me add "(1)","(2)", etc to files instead simply overwriting them. Does anybody knows how to turn it off? I simply want to overwrite file. I have default download folder turned off.

Thanks for your interest but this is off-topic. I kindly suggest posting a new thread for your problem.

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.