Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Downloads icon in Firefox is wrong color

  • 9 svar
  • 1 har dette problem
  • 90 visninger
  • Seneste svar af RogerDavis

more options

Downloads icon in Firefox is wrong color after moving to toolbar (black in icon choice display panel), disappears into background when in toolbar where it should be white while inactive like other icons.

How do I fix this?

Valgt løsning

The other machine is now 40 miles away, I won't be back there until Saturday. This one is the one where I can't see the Download icon at all.

I'm guessing you now refer to the machine where I can barely see the icon. Also guessing the way to check as you request is to right click it to find if it's set to auto-hide. I can do that on Saturday.

Now referring to the current machine - I can't see the icon anywhere, or a blank space for it, or any reference whatever to it. However, if it is auto hidden both on the toolbar and in the "reserve area" where icons not displayed on the toolbar are held, it might be hiding, but I can't find it in any way. All other icons seem to be there.

Is there an about:config reference?

EDIT browser.download.autohideButton;true Set to false?

EDIT 2 Yes, that works to bring back the icon from the dead. It seems to me that this should also be a bug that with the "true" setting it doesn't even show in the "reserve" space. FURTHER INFO - Now that I reset it in about:config, all seems normal, it is hidden on the toolbar, but appears when in customize mode now, and can be set to whatever is desired. I think this problem probably arose when it was set to autohide during the upgrade from 16.4 -> 18.04

Læs dette svar i sammenhæng 👍 0

Alle svar (9)

more options

Can you attach a screenshot?

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

more options

Problem icon is slightly darker blue - that is not a blank spot.

more options

You can add code to the userChrome.css file below the default @namespace line to modify the color.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#downloads-button { fill: white !important; }

more options

1) Given that this is not a normal condition, shouldn't it be entered as a bug? Or is this the intended way for it to appear?

2) I have a second very similar machine, and I just noticed that there is NO download icon on this one at all. How do I fix that ?

more options

Is the download button set to auto-hide if you check this via the right-click context menu (in customize mode use a left-click) ?

Keep in mind that Firefox version from the Ubuntu repositories can behave differently.

more options

Valgt løsning

The other machine is now 40 miles away, I won't be back there until Saturday. This one is the one where I can't see the Download icon at all.

I'm guessing you now refer to the machine where I can barely see the icon. Also guessing the way to check as you request is to right click it to find if it's set to auto-hide. I can do that on Saturday.

Now referring to the current machine - I can't see the icon anywhere, or a blank space for it, or any reference whatever to it. However, if it is auto hidden both on the toolbar and in the "reserve area" where icons not displayed on the toolbar are held, it might be hiding, but I can't find it in any way. All other icons seem to be there.

Is there an about:config reference?

EDIT browser.download.autohideButton;true Set to false?

EDIT 2 Yes, that works to bring back the icon from the dead. It seems to me that this should also be a bug that with the "true" setting it doesn't even show in the "reserve" space. FURTHER INFO - Now that I reset it in about:config, all seems normal, it is hidden on the toolbar, but appears when in customize mode now, and can be set to whatever is desired. I think this problem probably arose when it was set to autohide during the upgrade from 16.4 -> 18.04

Ændret af RogerDavis den

more options

The other machine, 40 miles away, remains to be seen what needs to be done. Of course this solution might (or might not) fix it.

more options

If it is auto-hidden on the toolbar then it should become visible in customize mode. If not the click Restore Defaults.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

This icon seems to be hidden when there are downloads in it. I deleted the downloads, it went back to not hidden.

This seems to be incorrect behavior.