Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Your connection is not secure

  • 1 svar
  • 1 har dette problem
  • 127 visninger
  • Seneste svar af cor-el

more options

I changed to Firefox to get away from Google but almost every website I try to access gives me the message "Your connection is not secure". I've never had this with Google so either every site I have ever visited is insecure or there is a problem with Firefox. I've tried some of the fixes but to be honest, I haven't the time so it's back to Google, sadly.

Kind Regards,

Mike

Alle svar (1)

more options

What security software do you have?

It is possible that your security software in intercepting the secure connection and sends its own certificate.

You can check if there is more detail available about the issuer of the certificate.

  • click the "Advanced" button show more detail
  • click the blue error text (SEC_ERROR_UNKNOWN_ISSUER) to show the certificate chain
  • click "Copy text to clipboard" and paste the base64 certificate chain text in a reply

If clicking the blue error text doesn't provide the certificate chain then try these steps to inspect the certificate.

  • open the Servers tab in the Certificate Manager
    • Options/Preferences -> Privacy & Security
      Certificates: View Certificates -> Servers: "Add Exception"
  • paste the URL of the website (https://xxx.xxx) in it's Location field

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate

You can see detail like the issuer of the certificate and intermediate certificates in the Details tab.