Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Addon buttons dissappear after restarting Firefox

  • 11 svar
  • 3 har dette problem
  • 636 visninger
  • Seneste svar af salivader

more options

I downloaded Firefox today and I'm trying to install uBlock and Zoom Page WE. I can install them just fine and their buttons will show up in the toolbar. However, if I close Firefox and open it again the buttons will be gone and the addons will only work in websites I had visited before restarting Firefox. They still show up in the addons menu and the buttons will show up again if I deactivate and activate the addons but as soon as I restart Firefox the buttons will be gone again. The addon buttons won't show up under the personalize menu either (even though I can move them there before closing Firefox).

Valgt løsning

Alle svar (11)

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete all extensions files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

more options

Thank you for the quick answer. I did as you said but it didn't solve the problem. I get a notification in the menu as if I had just installed them, but the buttons still dissappear if I restart Firefox.

more options

Would you give this a try :

Type in the address bar   about:config   (press Enter) (promise to be careful, if asked) Type and look for the preference :


Right-click it and choose 'Reset', to set it to its default value.

Does that work  ?

more options

I'm afraid not, the buttons still disappear :/

more options

Are there error messages in the Browser Console about these extensions directly after starting Firefox?

more options

I think so, please see the attached images. I opened Firefox, and then deactivated and activated the addons so that the buttons would show.

By the way I am now using Adblock, Zoom Page WE and HTTPS Everywhere, although nothing has changed regarding this problem.
more options

Okay, I think I found the problem. I made another user account to solve a separate issue I was having with OneDrive, and I had the idea to check if Firefox still had the same problem. It doesn't.

So I'm 99% the problem is due to a non-english letter I have in my user name (Á), the same reason I was having problems with OneDrive. Now I need to figure out how to change the folder's name.

more options

Do not change the folder name. This could lead to problems. Open the Firefox Profile Manager, and change the name from here.




Type about:profiles<enter> in the address bar.

more options

This is bug 1389160 (https://bugzil.la/1389160), fixed in 56.

more options

Valgt løsning

The correct link is; https://bugzil.la/1389160

more options

In the end I decided to make a clean install of Windows 10, I'd been wanting to do it for a while to improve my PC's performance anyway, and even if firefox fixed the bug the non-english character was still giving me problems for a bunch of other programs.

Thanks everybody :)