Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Though I have selected English in all options, red squiggle under words appears in all my social media posts, so how do I fix this?

  • 6 svar
  • 1 har dette problem
  • 13 visninger
  • Seneste svar af lesmaclock

more options

Though I have selected "English" in all my known options, the red squiggle under words appears in my social media posts, across all platforms.

I thought I had the language option set universally to English, by using the menu: (Tools>Options>Content>Languages)

Each time I go online, when the red squiggle appears, I click the squiggled word, right click for the menu, click "language" and change the language option from French back to English.

This works for all platforms, but for just the one session. Next time I go online I must re-select the language option.

Solutions anyone?

Though I have selected "English" in all my known options, the red squiggle under words appears in my social media posts, across all platforms. I thought I had the language option set universally to English, by using the menu: (Tools>Options>Content>Languages) Each time I go online, when the red squiggle appears, I click the squiggled word, right click for the menu, click "language" and change the language option from French back to English. This works for all platforms, but for just the one session. Next time I go online I must re-select the language option. Solutions anyone?

Alle svar (6)

more options

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.


You may have a corrupt localstore.rdf file. https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved


delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

more options

Please forgive me, I can drive the car, but can't change the oil. Your reply is way over my head! This red squiggle thing has been going on for a very long time - easily over a year. I'm sure your response would be quite helpful for someone who is a bit more savvy than I am, but I don't know what "anti-virus add-ons" are. I wouldn't disable anything I'm not 100% certain about and I am very careful about sites I visit and applications I use.

Unfortunately, the support URL you've kindly mentioned in your reply doesn't look like it would solve the red squiggles problem I am dealing with.

Your answer leads me to so many more questions! What is localstore.rdf file? What is search.json and search-metadata.json and search.sqlite? Why would I reset search engine to default? What would that do to the personalized refinements I have carefully and gradually made over time?

Isn't there a simple way to get rid of the red squiggles without having to change the language every time I turn on my computer? Oh, dear! I used to think I was pretty smart!

BUT . . . 

Please don't give up on me! Lesley

more options

Firefox can change the dictionary language based upon the language setting that the website sends via the page source. This forum sends for me (Firefox/Tools > Web Developer > Page Source; Ctrl+U):

<html class="no-js" lang="en-US" dir="ltr">
more options

So what do I need to do with It does not mean anything to me.

more options

Type about:preferences<Enter> in the address bar.

Select Content. On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district is selected.

more options

FredMcD! I think that DID IT! From tools > options, etc, it did not work, but as you suggested, from about:preferences, it seems to. I've only checked my posts on FB, so, I'll let you know if that doesn't follow through with the other social media accounts. BIG THANK YOU!