Řešení problémů se zásuvnými moduly

Pokud máte problémy s webovými stránkami, které používají pro zobrazování obsahu zásuvné moduly (jako například Flash, Java a další), budete muset zjistit, který zásuvný modul (plugin) problém způsobuje.

Nejčastější problémy způsobené zásuvnými moduly jsou:

Tento článek popisuje, jak problémy se zásuvnými moduly vyřešit. Pokud máte problém s rozšířením či doplňkem vzhledu, přečtěte si článek Řešení problémů s rozšířeními a motivy vzhledu. Obecné informace o zásuvných modulech naleznete v článku Používání zásuvných modulů ve Firefoxu.

Zjištění, zda je zdrojem problému zásuvný modul

Za běhu Firefoxu máte možnost konkrétní zásuvné moduly zakázat. Pokud máte podezření, že problém způsobuje konkrétní zásuvný modul, zakažte jej jako první a vyzkoušejte, zda je tomu tak. Pokud nevíte, který zásuvný modul zakázat, postupujte následovně:

  1. V horní části okna Firefoxu klepněte na tlačítko Firefox Na liště s nabídkou klepněte na nabídku NástrojeV horní části okna Firefoxu klepněte na nabídku Nástroje a poté na položku Správce doplňků. Otevře se panel Správce doplňků. Zobrazte nabídku klepnutím na tlačítko New Fx Menu a zvolte Správce doplňků. Otevře se panel Správce doplňků.

  2. Ve Správci doplňků přejděte do sekce Zásuvné moduly.Ve Správci doplňků přejděte do sekce Zásuvné moduly.
  3. Zvolte zásuvný modul v seznamu a klepněte na tlačítko Zakázat. Opakujte tento postup pro každý zásuvný modul v seznamu, dokud nebudou všechny zakázány. Pro aktivaci změn není potřeba Firefox restartovat.
  4. Vyzkoušejte, zda se problém stále vyskytuje. Pokud ne, přejděte zpět do Správce doplňků a po jednom zkoušejte zásuvné moduly povolovat pomocí tlačítka Povolit. Vše do té doby, dokud nenaleznete zdroj problému.
  1. V horní části okna Firefoxu klepněte na tlačítko Firefox Na liště s nabídkou klepněte na nabídku NástrojeV horní části okna Firefoxu klepněte na nabídku Nástroje a poté na položku Správce doplňků. Otevře se panel Správce doplňků. Zobrazte nabídku klepnutím na tlačítko New Fx Menu a zvolte Správce doplňků. Otevře se panel Správce doplňků.

  2. Ve Správci doplňků přejděte do sekce Zásuvné moduly.Ve Správci doplňků přejděte do sekce Zásuvné moduly.
  3. Zvolte zásuvný modul v seznamu a z jeho rozbalovací nabídky vyberte Nespouštět. Opakujte tento postup pro každý zásuvný modul v seznamu, dokud nebudou všechny zakázány. Pro aktivaci změn není potřeba Firefox restartovat.
  4. Vyzkoušejte, zda se problém stále vyskytuje. Pokud ne, přejděte zpět do Správce doplňků a po jednom zkoušejte zásuvné moduly povolovat vybráním Vždy spusit z jejich rozbalovací nabídky. Vše do té doby, dokud nenaleznete zdroj problému.

Pokud naleznete zásuvný modul, který způsobuje váš problém, pokračujte v následujících krocích v tomto článku.

Aktualizace nebo reinstalace zásuvných modulů

Řada problémů se zásuvnými moduly může být odstraněna aktualizací na poslední verzi zásuvného modulu. Pro kontrolu aktuálnosti zásuvných modulů přejděte na stránku Kontrola zásuvných modulů

Pokud aktualizace na novější verzi zásuvného modulu či jeho reinstalace nepomohou, můžete nechat zásuvný modul zakázaný.

Ruční odinstalace zásuvného modulu

Pokud nemáte možnost použít na odstranění zásuvného modulu odinstalátor, je možné jej odstranit ručně:

  1. Do adresního řádku zadejte about:config a stiskněte klávesu EnterReturn.

    • Při vstupu se může zobrazit upozornění "Vstup jen na vlastní nebezpečí". Pokračovat na stránku about:config budete po klepnutí na tlačítko Budu opatrný, slibuji!.
  2. Vyhledejte předvolbu plugin.expose_full_path.
  3. Dvojklepněte na předvolbu plugin.expose_full_path a nastavte její hodnotu na true.
  4. Do adresního řádku zadejte about:plugins a stiskněte EnterReturn, čímž zobrazíte seznam nainstalovaných zásuvných modulů.
  5. Každá položka na stránce obsahuje text "Název souboru:", za nímž následuje cesta k zásuvnému modulu. Pomocí programu Průzkumník Windows přejděte doPřejděte do složky, kde je umístěn zásuvný modul, který chcete odstranit.
  6. Přejmenujte soubor zásuvného modulu přidáním X před jeho název. Např. npswf32 na Xnpswf32.
  7. Na konfigurační stránce about:config dvojklepněte na předvolbu plugin.expose_full_path a změňte tak její hodnotu na false, čímž zamezíte webovým stránkám hádat, kde by mohl být zásuvný modul umístěn.

Zásuvný modul jste tím z Firefoxu odstranili.

Pokud nemáte možnost použít na odstranění zásuvného modulu odinstalátor, je možné jej odstranit ručně:

  1. Do adresního řádku zadejte about:plugins a stiskněte klávesu EnterReturn. Zobrazí se seznam nainstalovaných zásuvných modulů.
  2. Každá položka na stránce obsahuje text "Název souboru:", za nímž následuje název souboru zásuvného modulu. Chcete-li zjistit umístění každého ze zásuvných modulů, můžete se podívat do souboru "pluginreg.dat" (pomocí textového editoru), nacházejícího se ve složce s vaším profilem. Pomocí programu Průzkumník Windows potom přejděte doPoté přejděte do složky, kde je umístěn zásuvný modul, který chcete odstranit.
  3. Přejmenujte soubor zásuvného modulu přidáním X před jeho název. Např. npswf32 na Xnpswf32.

Zásuvný modul jste tím z Firefoxu odstranili.

Pokud nemáte možnost použít na odstranění zásuvného modulu odinstalátor, je možné jej odstranit ručně:

  1. Do adresního řádku zadejte about:plugins a stiskněte klávesu EnterReturn. Zobrazí se seznam nainstalovaných zásuvných modulů.
  2. Každá položka na stránce obsahuje text "Soubor:" a "Cesta:", kde jsou uvedeny název a umístění souboru zásuvného modulu. Pomocí programu Průzkumník Windows přejděte doPřejděte do složky, kde je umístěn zásuvný modul, který chcete odstranit.
  3. Přejmenujte soubor zásuvného modulu přidáním X před jeho název. Např. npswf32 na Xnpswf32.

Zásuvný modul jste tím z Firefoxu odstranili.

Opětovná inicializace databáze zásuvných modulů

V některých případech, kdy nejste schopni nainstalovat či přeinstalovat zásuvný modul, vám pomůže opětovná inicializace databáze zásuvných modulů:

  1. Otevřete svou složku s profilem:

    V horní části okna Firefoxu klepněte na tlačítko Firefox, přejeďte do nabídky NápovědaNa liště s nabídkou klepněte na nabídku NápovědaV horní části okna Firefoxu klepněte na nabídku Nápověda a zvolte položku Technické informace.... Otevře se panel Technické informace.Zobrazte nabídku klepnutím na tlačítko New Fx Menu , v ní klepněte na Help-29 a zvolte Technické informace. Otevře se panel Technické informace.

  2. V sekci Stručně o aplikaci klepněte na tlačítko Zobrazit složkuZobrazit ve FinderuOtevřít adresář. Otevře se okno se soubory vašeho profilusložkou s vaším profilem.
  3. Poznámka: Pokud nemůžete spustit či použít Firefox, postupujte dle instrukcí v článku Nalezní profilu bez otevření Firefoxu.

  4. V horní části okna Firefoxu klepněte na tlačítko Firefox, kde zvolte položku UkončitV horní části okna Firefoxu klepněte na nabídku Soubor, kde zvolte položku UkončitNa liště s hlavní nabídkou klepněte na nabídku Firefox, kde zvolte položku Ukončit FirefoxV horní části okna Firefoxu klepněte na nabídku Soubor, kde zvolte položku Ukončit.

    Zobrazte nabídku klepnutím na tlačítko New Fx Menu a v ní klepněte na Ukončit Close 29 .

  5. Smažte soubor pluginreg.dat.
  6. Spusťte Firefox.
  7. V adresním řádku zadejte about:plugins a stiskněte klávesu EnterReturn. Zobrazí se vám seznam nainstalovaných zásuvných modulů.



Sdílet tento článek: http://mzl.la/NYtGci

Byl tento článek srozumitelný? Počkejte prosím...

Tito lidé pomohli se sepsáním tohoto článku: JasnaPaka, soucet. Můžete též pomoci - přečtěte si jak.