Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Amazon Prime Video: "Mozilla FIrefox update required"

  • 2 odgovori
  • 2 ima ovaj problem
  • 9 views
  • Posljednji odgovor poslao FredMcD

more options

Firefox 90.0.02 64-bit: error from Amazon Prime Video: "Mozilla FIrefox update required."

Priloženi snimci ekrana

All Replies (2)

more options

Helpful?

more options

Websites say that Firefox is outdated or incompatible even though it's the latest version

https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

You can check out at the browserspy website how websites see you:

http://browserspy.dk/browser.php
http://browserspy.dk/headers.php

Helpful?

Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.