Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

System Requirements incorrectly posted by Yahoo. Yahoo posts Firefox 4 is OK on Mac G5. But not true.

  • 1 reply
  • 15 have this problem
  • 7 views
  • Last reply by cor-el

more options

I use a Mac PPC G5, OS 10.5.8, with Firefox 3.6.17, and use Yahoo! for my Homepage.

PLEASE NOTE: Yahoo! is now (incorrectly) posting the following for an "Optimized for Yahoo!" Firefox 4 download:

System Requirements: Operating Systems: Mac OS X 10.4 or later Minimum Hardware: Macintosh computer with an Intel x86 or PowerPC G3, G4, or G5 processor 128 MB RAM (Recommended: 256 MB RAM or greater) 200 MB hard drive space

Their link downloads a version of Firefox 4 that is not compatible with my system. QUESTION: Will there ever be a Firefox 4 version for the (non-intel) Mac PPC G5?

If not, I suggest Mozilla should have Yahoo! correct their Firefox upgrade system requirement posting specs, yes?

Thank you.

All Replies (1)

more options

Firefox 4 requires at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 4 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here.
This may change as Firefox 5 gets released next week.