ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable automatic download when browsing

  • 11 ردًا
  • 1 has this problem
  • 31 views
  • آخر ردّ كتبه zeroknight

more options

How do I stop firefox from automatically downloading files from the internet when I click on them - without even asking me if I want to download them in the first place. In "Applications", selecting "Always Ask" in "Choose how firefox handles files etc" does not work. Firefox never asks. If it cannot be disabled, I will have to stop using Firefox.

How do I stop firefox from automatically downloading files from the internet when I click on them - without even asking me if I want to download them in the first place. In "Applications", selecting "Always Ask" in "Choose how firefox handles files etc" does not work. Firefox never asks. If it cannot be disabled, I will have to stop using Firefox.

All Replies (11)

more options

What file type? Sometimes servers report the wrong file type, can you give an example link?

Make sure "Always ask you where to save files" is enabled, all content type actions are set to "Always ask" and "What should Firefox do with other files?" is set to "Ask whether to open or save files".

Helpful?

more options

Definitely file types .jpeg and Adobe Acrobat document (pdf) Content actions are set to "Always ask" but firefox still saves the file without asking anything. Here is an example of a link: (see also screen shot: When I click on Nieuwendijk, firefox saves the pdf to Downloads without asking anything) https://www.amsterdam.nl/parkeren/gemeentelijke-parkeergarages/parkeergarages-vergunninghouders/?adres=Nieuwezijds+Voorburgwal+45%2C+1012RD+Amsterdam

Helpful?

more options

Check the list in the Applications box. By default, PDFs are set to "Open in Firefox." You might prefer "Save file" or "Always ask."

Helpful?

more options

Just to clarify, check "Portable Document Format (PDF)" and not one of the Acrobat ones.

Helpful?

more options

In Applications, the PDF is set to "Always Ask" (as is jpeg and more) - nevertheless, Firefox saves the files without asking. So the whole Applications section does not seem to have any purpose. Firefox does what it wants and ignores what I have set Firefox to do.

Helpful?

more options

Your example works for me, clicking the link shows the "What should Firefox do with this file?" dialog when "Portable Document Format (PDF)" is set to "Always ask".

Does it still happen in Troubleshoot Mode?

Helpful?

more options

To zeroknight: I also get the dialog box but AT THE SAME TIME, Firefox ALSO saves it automatically to Downloads without asking me.

Helpful?

more options

To stop Firefox from automatically downloading files without asking, you can follow these steps:

Open Firefox and type "about:preferences" in the address bar and hit Enter. In the Preferences window, click on "General" on the left sidebar. Scroll down to the "Downloads" section. Uncheck the box next to "Always ask you where to save files." By unchecking this option, Firefox will no longer prompt you to choose a download location for each file you download. Instead, files will be automatically saved to your designated download folder without asking for confirmation.

If you prefer to be prompted each time before a file is downloaded, you can leave the "Always ask you where to save files" option checked.

Helpful?

more options

To Muhammad Rikaz Khan: what you're suggesting me to do is exactly what i do NOT want. And you're contradicting yourself: "To stop Firefox from automatically downloading files ..." .... "Instead, files will be automatically saved ..."

Helpful?

more options

whellebrand said

To zeroknight: I also get the dialog box but AT THE SAME TIME, Firefox ALSO saves it automatically to Downloads without asking me.

Aha, now I see what you mean. While Firefox shows the Open/Save/Cancel dialog, it is downloading the file in the background (you will see a file with a .part file extension start to grow in your designated downloads folder). This is because the most common action after starting a download is to Open or Save, and both require saving the file.

I am not aware of a way to prevent Firefox from downloading in the background while the dialog is displayed.

However, if you prefer that Firefox use the Windows Temp folder for the .part files, you can change a little known setting for that. Here's how you access it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.start_downloads_in_tmp_dir and pause while the list is filtered

(3) Double-click the preference (or click the toggle button at the right end of the row) to switch the value from false to true

Helpful?

more options

Set the default action to save without asking and you can use an extension like Android Download Prompt to prevent any downloading.

Helpful?

اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.