ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to configure scroll speed deceleration when using touch screen

  • 3 ردود
  • 0 have this problem
  • 61 views
  • آخر ردّ كتبه cor-el

more options

I am having a hard time getting accustomed to the Firefox scrolling experience. I am only using the touch pad and the touch screen. When I release the finger the time it takes for the scroll speed to come to a halt is way longer than on Chromium browsers and uncomfortable. I want to configure this to decelerate faster or to remove the smoothing completely.

I have tried playing around with scroll configurations and I found that setting apz.gtk.kinetic_scroll.enabled =false disables smoothing correctly, but only works for touch pad, not for touch screen.

- Is there some config I am missing to disable this kinetic scroll using touch screen? - Is there a preference where I can halve the time it takes to decelerate, rather than disable it completely?

I am running Ubuntu 22.04 on Wayland if that makes a difference.

I am having a hard time getting accustomed to the Firefox scrolling experience. I am only using the touch pad and the touch screen. When I release the finger the time it takes for the scroll speed to come to a halt is way longer than on Chromium browsers and uncomfortable. I want to configure this to decelerate faster or to remove the smoothing completely. I have tried playing around with scroll configurations and I found that setting '''apz.gtk.kinetic_scroll.enabled''' =false disables smoothing correctly, but only works for touch pad, not for touch screen. - Is there some config I am missing to disable this kinetic scroll using touch screen? - Is there a preference where I can halve the time it takes to decelerate, rather than disable it completely? I am running Ubuntu 22.04 on Wayland if that makes a difference.

الحل المُختار

Try increasing apz.fling_friction to 0.9 in about:config.

Read this answer in context 👍 2

All Replies (3)

more options

الحل المُختار

Try increasing apz.fling_friction to 0.9 in about:config.

Helpful?

more options

That's great, thanks! I set it to 0.006 and now it's much closer to what I expect. It works the same for both touch pad and touch screen. All the apz.fling_* properties allow for some in depth configuration of the scrolling.

Helpful?

more options

Helpful?

اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.