Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't load youtube in firefox

  • 11 replies
  • 7 have this problem
  • 225 views
  • آخر ردّ كتبه jscher2000

more options

When I open youtube, there´s nothing wrong. But when I sign in with my account, the page stops working. It only happens with firefox, chrome an edge doesn't do that.

Attached screenshots

All Replies (11)

more options

update: I discovered that i can open youtube, but only if a click on a video link. Whenever I try to open youtube from the main page, it just stops working

more options

That's strange. There is a lot more complexity on the main page when you are signed in related to all your various lists you build over time in YouTube, so maybe there is some kind of blockage or corruption related to one of those. ??

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

I tried every solution, and none worked. Safe mode, erase extensions (by the way, the only extension I had installed before was Grammarly) disabling/enabling Tracking Protection. Clearing cache data worked, but the second i logged my google account, YouTube glitched again. But I noticed something weird. Tracking Protection blocked 48 trackers from YouTube yesterday, and 3 Today (that was before all of this happened). Could that be related?

more options

Maybe the trackers aren't loading today since nothing else is loading? I don't have any new ideas at the moment.

Actually, could you check this storage diagnostic to see whether any storage features have stopped working in your Firefox? It's sometimes slow to start.

https://firefox-storage-test.glitch.me/

more options

It says that storage is working. I guess I'll run a scan searching for viruses and see what happens. Thanks for the help!

more options

I ran Windows defender and after that avast, there was no virus. So I decided to just stop using Firefox for a while, and now YouTube is working again.

more options

I have a very similar issue. Youtube when logout works OK. As soon as I login in, I have to refresh the page a random number of times (sometimes once will work, other times 5). It is only happening in my two linux machines running 76.0.1. Windows is working OK, but I have to check the version I am running there.

more options

I have a similar problem. I can't use YouTube with Firefox on Mac. When I open Youtube, it acts like it i stuck and keeps reloading a previous page, over and over every 3 seconds so I can't click on anything. Strange. Yes, I cleared the Cache and it didn't help. I had an old mac and had the same problem and my new mac was just purchased this year. Any ideas?

more options

Hi Gordon, since your Firefox is behaving quite differently, let's discuss that in your new question here:

https://support.mozilla.org/questions/1288447

more options

Hello guys This is my experience with Firefox and YouTube I suppose the security options and block sites / verify / certificates could be the issue. Video demo Firefox and Edge Redirection, clicking in links or menus is not working properly on Youtube Channels, some other channels without problem.

more options

Hi George, if I understand the problem, the main content of the page doesn't load on the first try, you have to reload.

Does it work in a private window, logged out of your Google account?


If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?