Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

MY Bookmark Toolbar folders move and switch order

  • 3 replies
  • 1 has this problem
  • 12 views
  • آخر ردّ كتبه cor-el

more options

I have twelve sites (or folders) on my bookmark toolbar. This morning the order of the bookmarks was changed. I moved the bookmarks back to my preferred order and after using Firefox for 1 hour, the bookmark order changed again. I used to have many more bookmarks on the toolbar, but after they started moving, I moved all but twelve to "other bookmarks". Anything you can do to stop moving the bookmarks would be appreciated! Thank you. Chris

All Replies (3)

more options

Hi chris76ford,

Are you referring to the actual bookmarks changing order? Or is it the order of the URLS you added to each bookmark.

If you have any extensions that may be rearranging your bookmarks you could try disabling them.

Have you tried arranging the bookmarks in your Library? You can sort your bookmarks by name or manually to your liking.

See also : Sort your bookmarks to quickly find the ones you want

If you are using the Views menu this will not sort bookmarks permanently.

See also : After sorting the bookmarks do not stay sorted. why?

Hope this helps!

Modified by WMagicModel

more options

Are you using Sync?

If so, disconnect that device from the Sync server before re-arranging your bookmarks. Then restart Firefox before connecting back to Sync.


Further: Are you using Sync with either Firefox for iOS or Firefox for Android?

If so, that or those devices might be the cause of the bookmarks toolbar folders to become disorder to begin with.


If you aren't using Sync, it might be a good idea to open about:support / Troubleshooting Information from the Help menu, and near the bottom use the Places Database > Verify Integrity button to check the Places Database file for corruption.

more options

I notice a bookmarks related extension in the System Details list.

  • Bookmark Dupes 5.10 (bookmarkdupes@martin-vaeth.org)

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window