ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can not get drop down tabs in Yahoo Finance to open.

  • 10 ردود
  • 2 have this problem
  • 91 views
  • آخر ردّ كتبه Les

more options

When I open Yahoo Finance and go to the "My Portfolio" tab and get the drop down menu for that tab, it will not open the tab I click on.

All Replies (10)

more options

Hi Steve,

You could try refreshing the Yahoo Finance website to see if that helps by holding CONTROL, SHIFT and R. Or you can achieve this by clicking the swirly-arrow icon next to your home page icon on the top left corner of your Firefox browser.

Are other websites loading properly or is it just Yahoo Finance?

Try launching another web browser such as Edge or Chrome to see if the patterns are the same for the Yahoo Finance "My Portfolio" tab.

Hope this helps!

more options

Other websites load properly, it is just Yahoo Finance and also Yahoo Sports. I did launch Chrome and Yahoo Finance loads and works properly. I would like to use Firefox.

more options

Hi Steve, I don't have anything set up in Yahoo Finance, so I can't test for myself, but can you tell whether it is pure HTML or also uses the Flash plugin?

For Flash, see: Why do I have to click to activate plugins?


If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

I have a similar problem. Here is a writeup (below) I did but the bottom line is I think something is wacky with Firefox and hopefully a new release will fix this. In the mean time workarounds are (1) click on link and bring up in new tab, (2) use another browser for the Yahoo site.

=============

I was on vacation for 4 weeks. Now my PC seems to have problems when I navigate to Yahoo using Firefox and click on a link. If I navigate to Yahoo and click on a link in that page nothing happens. Yahoo Mail links work fine though. If I open the link using "Open in new tab" I can bring up that link in a new tab. But just clicking the link does not work.

When I do the same thing in the Edge browser all is fine. I simply navigate to Yahoo and can click on any link with normal results. If I log into my computer as Administrator, Yahoo works as expected.

I have done the obvious things like rebooting the PC and installing any new software and logging out of Yahoo and back in.

more options

I tried Firefox in safe mode and the problem goes away. But how do I get this behavior in normal mode? I did clear the cookies and site data but still the problem persists in normal mode.

BTW, I am using a Windows 10 PC which should be fully up to date.

more options

Hi Les, Firefox's Safe Mode does these things:

(A) Disables all extensions -- a common culprit if you use any blockers or page modifiers -- more discussion below

(B) Disables hardware acceleration of graphics/videos -- doesn't seem relevant to nonworking links, but if you want to try it in regular mode, this article describes where to make that change: Firefox's performance settings. This will take effect the next time you exit Firefox and start it up again. Any difference?

Since hardware acceleration improves the appearance of fonts and animations, you may want to check whether graphics card/chipset driver updates are available for your system. This article suggests safe ways to do that: Upgrade your graphics drivers to use hardware acceleration and WebGL.

(C) Disables the custom styling files userChrome.css and userContent.css which most people do not use (so not likely to be the issue)

(D) Disables the "just in time" JavaScript compilers -- shouldn't affect basic links

(E) Probably some other stuff I'm forgetting


Investigating Extensions

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that is designed to modify links, or that you just do not remember installing or why? Anything you can live without for 12 hours? If in doubt, disable (or remove).

Any improvement after reloading the News page?

For those you keep enabled:

Many extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix provide toolbar buttons indicating what they are blocking in the page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Can you track it down?

more options

Hi jscher2000,

I disabled Norton Safe Web and the problem went away. I can now follow links on Yahoo finance.

Do you think I should just keep it disabled? Feels less safe but what do I know. :)

Thanks for your help!

Les

more options

Les said

I disabled Norton Safe Web and the problem went away. I can now follow links on Yahoo finance. Do you think I should just keep it disabled? Feels less safe but what do I know. :)

Hi Les, I suggest bubbling it up to Norton. They either have some reason for it or it's a bug. But I couldn't tell you either way.

more options

I spent 2 hours on the phone with Norton and finally convinced them the problem was with their add-on. Next day the add-on was updated and all seems to work properly now.

more options

Thanks GB for contacting Norton and spending the time to resolve this. Norton Safe Web seems to be fixed now as regards to Yahoo finance drop down tabs.