Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

how do i fix my keyboard typing the wrong letters in firefox but not in other programs?

  • 19 replies
  • 2 have this problem
  • 31 views
  • آخر ردّ كتبه AliceWyman

more options

when i type the alpha numerics in order this is what i get. It should look like this. AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPpQqRrSsTtUuVvWwXxYyZz1234567890,./;'[]\-= but i get this instead, AaBbMmDdEeFfGgHhIiJjKkLlMmUuOoPpQqRrSsTtUuVvWwLlYyZz1234567890,./p2[]a-= the keys are random and never consistent. i am using a standard qwerty keyboard. logitech G105 backlit membrane. i am having to type in other programs like note pad or discord just to copy paste. just like i am having to do right now.

All Replies (19)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

well im typiug here as i uortally should but it doesut seet to be workiugs {well im typing here as i usually should but it doesnt seem to be working.}

more options

Did you try to reboot the computer ?

Do you have multiple keyboard layouts installed in Windows ? You may have switched accidentally to another layout.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

booting in safemode with networking didnt work and the only layout i have installed is qwerty

more options

Hello puddlejumper,

Try hitting the NUM LOCK/SCRN LOCK key (if you have such key).

Try hitting CTRL and Shift at the same time (this one worked for me, but my problem with the keyboard was not the same as yours, though).

More suggestions : https://www.auslogics.com/en/articles/fixing-windows-10-keyboard-types-the-wrong-characters/

And : https://www.wikihow.com/Fix-a-Keyboard-That-Has-the-Wrong-Characters

Any good ?

more options

screen lock is off numlock is on ctrl shift did nothing, still jumbled letters.

more options

puddlejumper6999 said

screen lock is off numlock is on ctrl shift did nothing, still jumbled letters.

Numlock should be OFF .....

How about the two articles I gave you links to ?

more options

Your initial post shows that only 'c' and 'x' and some symbols are affected. Are always these specific characters affected?

This can't be about status keys, but would be caused by a wrong keyboard layout or some software that modifies the keyboard scan codes.

Are you sure that you only have one keyboard layout installed (i,e, did you check this)?

more options

numlock on a desktop pc shouldnt make a difference. but even with numlock off still jumbles. the keys effected are random. and those 2 links didnt help.yes and the only software that would alter keyboard layout is my LGS software for the G key macros on my G105

more options

Do you have this problem with Firefox only, or does it also happen when you use e.g. Edge ?

Should that be the case, and none of our suggestions are helpful to you; maybe you could post your question on Microsoft's official support forum:

www.answers.microsoft.com/windows

more options

I only happens to me in firefox and for whatever reason i can type here normally. the only thing i did was put it to sleep like i do every night. im so confused as to why its doing this.

more options

puddlejumper6999 said

I only happens to me in firefox and for whatever reason i can type here normally. the only thing i did was put it to sleep like i do every night. im so confused as to why its doing this.

Well, maybe that's all it needed : a good night's sleep .....

But all kidding aside : wait and see what happens - let us know if the problem comes back, will you ?

more options

will do. whats wierd tho is this issue has been present for about a week and put to sleep everynight for 8+hours.

more options

puddlejumper6999 said

will do. whats wierd tho is this issue has been present for about a week and put to sleep everynight for 8+hours.

Just a guess : the latest Windows update (about 36 hours ago for me) might have something to do with it ......

But fingers crossed that the problem won't be back.

more options

Are you putting Firefox to sleep, or the computer? Many report issues when their computer 'wakes up.'

more options

FredMcD said

Are you putting Firefox to sleep, or the computer? Many report issues when their computer 'wakes up.'

i was putting the pc to sleep.

more options

Both FF and T (and only them) use a wrong keyb layout. Of course there's a workaround (using setxkbmap) but I wonder why this happens since it's kind of common configuration (the whole system is en_US but keyboard is an azerty so configured as French legacy, alt). $ cat /etc/default/locale LANG=en_US.UTF-8 LANGUAGE=en_US:en LC_NUMERIC=fr_FR.UTF-8 LC_TIME=fr_FR.UTF-8 LC_MONETARY=fr_FR.UTF-8 LC_PAPER=fr_FR.UTF-8 LC_MEASUREMENT=fr_FR.UTF-8

Any hint ? Thx

more options

alte94 Please go to the top of any support.mozilla.org web page and use the Get Community Support link: https://support.mozilla.org/en-US/questions/new

Select the product for what the problem is (Firefox or whatever). Now select the category for the problem. At the bottom is Other.

Describe the problem in brief (one line). Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.

more options

alte94 said

Both FF and T (and only them) use a wrong keyb layout. Of course there's a workaround (using setxkbmap) but I wonder why this happens since it's kind of common configuration (the whole system is en_US but keyboard is an azerty so configured as French legacy, alt).
$ cat /etc/default/locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_MONETARY=fr_FR.UTF-8
LC_PAPER=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
Any hint ? Thx


If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected by a team of people who read it and gather data about the most common issues.

If you are asking for support, please ask a new question as Fred suggested. See Forum rules and guidelines. I'll close this thread since it is for helping puddlejumper6999 who posted the original question in August 2019.