X
Tap here to go to the mobile version of the site.

منتدى الدعم

adblockplus was just disabled in my firefox v52.9.0 browser, on my Windows XP computer. How can I reactivate?

Posted

This morning Adblock Plus was disabled in my browser.

the message n the EXTENSIONS PAGE reads: "Adblock Plus - free ad blocker could not be verified for use in Firefox and has been disabled".

I've been Adblock PLus using for years, on both my computers. And it still functions on my Windows 10 desktop. Is this because it is Windows XP? Can I do anything to reacivate it?

I tried to add Adblock Plus again on the computer - but that did not work either. I get a message that says: "Download failed. Please check your connection' - but I am using the connection without problems everywhere else!

This morning Adblock Plus was disabled in my browser. the message n the EXTENSIONS PAGE reads: "Adblock Plus - free ad blocker could not be verified for use in Firefox and has been disabled". I've been Adblock PLus using for years, on both my computers. And it still functions on my Windows 10 desktop. Is this because it is Windows XP? Can I do anything to reacivate it? I tried to add Adblock Plus again on the computer - but that did not work either. I get a message that says: "Download failed. Please check your connection' - but I am using the connection without problems everywhere else!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

wendiwoman2 1 solutions 8 answers

Thanks for the quick reply. I'm attaching two screenshots. The first, "ClickingLink.jpg" is from immediately after trying to import by clicking your link. The second, "Importing.jpg", is from the message the appeared immediately after I tried to import. Neither were successful. Wendi

Thanks for the quick reply. I'm attaching two screenshots. The first, "ClickingLink.jpg" is from immediately after trying to import by clicking your link. The second, "Importing.jpg", is from the message the appeared immediately after I tried to import. Neither were successful. Wendi
jscher2000
  • Top 10 Contributor
8632 solutions 70604 answers

Hi wendiwoman2, unfortunately, it really isn't telling us anything new, other than it tried and something went wrong.

Could you try exporting the certificate from your working profile to your non-working profile?

In the working profile, open the Certificate Manager --

Options > Advanced > Certificates > View Certificates

On the Authorities tab, scroll down to Mozilla Corp as the issuer and click the certificate there to select it. Then click Export and save in the default format to a convenient location.

Then in the non-working profile, can you try to import that certificate and see whether it works?

Hi wendiwoman2, unfortunately, it really isn't telling us anything new, other than it tried and something went wrong. Could you try exporting the certificate from your working profile to your non-working profile? In the working profile, open the Certificate Manager -- Options > Advanced > Certificates > View Certificates On the Authorities tab, scroll down to Mozilla Corp as the issuer and click the certificate there to select it. Then click Export and save in the default format to a convenient location. Then in the non-working profile, can you try to import that certificate and see whether it works?
wendiwoman2 1 solutions 8 answers

I actually tried that earlier, before seeking help. It didn't work either. And as part of investigating, I compared the exported certificate with the one I downloaded from your site, and, as expected, they were identical.

I actually tried that earlier, before seeking help. It didn't work either. And as part of investigating, I compared the exported certificate with the one I downloaded from your site, and, as expected, they were identical.
wendiwoman2 1 solutions 8 answers

Since it seems likely that this problem is somehow related to the specific profile, is there any setting in prefs.js that might prevent the installing of a new certificate?

Since it seems likely that this problem is somehow related to the specific profile, is there any setting in prefs.js that might prevent the installing of a new certificate?
jscher2000
  • Top 10 Contributor
8632 solutions 70604 answers

Hi wendiwoman2, does the problem profile have a master password set? If so, could you go ahead and enter it before trying to import the certificate again (you can use the Saved Logins button to trigger a request).

That is based on comments in the following bug report. I don't know if it the problem exists in pre-Quantum Firefox, but I thought it was worth mentioning.

https://bugzilla.mozilla.org/show_bug.cgi?id=1549249

Hi wendiwoman2, does the problem profile have a master password set? If so, could you go ahead and enter it before trying to import the certificate again (you can use the Saved Logins button to trigger a request). That is based on comments in the following bug report. I don't know if it the problem exists in pre-Quantum Firefox, but I thought it was worth mentioning. https://bugzilla.mozilla.org/show_bug.cgi?id=1549249
wendiwoman2 1 solutions 8 answers

No master password. And from my perspective as a FF user, not a developer, the two profiles are supposed to behave the same. Of course, after many years of using each, there are many differences when I compare the two prefs.js, although I don't understand the significance of many of the differences.

No master password. And from my perspective as a FF user, not a developer, the two profiles are supposed to behave the same. Of course, after many years of using each, there are many differences when I compare the two prefs.js, although I don't understand the significance of many of the differences.
wendiwoman2 1 solutions 8 answers

I got it! I deleted (well, actually, I renamed) cert8.db and key3.db, then started FF. Now it let me install the certificate, and my add-ons are working again. Maybe one of the two files was corrupted? In any case, things are good again. I thank you profusely for devoting so much of your time and brain power to helping me out. Wendi

I got it! I deleted (well, actually, I renamed) cert8.db and key3.db, then started FF. Now it let me install the certificate, and my add-ons are working again. Maybe one of the two files was corrupted? In any case, things are good again. I thank you profusely for devoting so much of your time and brain power to helping me out. Wendi
jscher2000
  • Top 10 Contributor
8632 solutions 70604 answers

Hi wendiwoman2, thanks for the update. I was going to suggest maybe "transplanting" the working cert8.db across to the other profile, but a fresh start probably is best.

Hi wendiwoman2, thanks for the update. I was going to suggest maybe "transplanting" the working cert8.db across to the other profile, but a fresh start probably is best.
W1shb0ne_Snap 0 solutions 2 answers

jscher2000 said

Hi Matt, I was able to start testing in Firefox 52 ESR. When I install the hotfix extension, nothing happens, other than showing up on the Extensions panel of the Add-ons page. In the Browser Console, I see this message: TypeError: browser.experiments is undefined That means the main command of the extension doesn't run, so it's a dead end.

Next idea:

Overview

(1) Install the certificate the hotfix would have installed (2) Trigger Firefox to re-verify your extensions (3) Wait until it is back to normal

Steps

(1) Install certificate

I extracted the certificate from my Firefox 66 and saved it on my webserver. Obviously if you don't trust me, you should not install it.

Two possible methods: click to download through the certificate installer, or right-click > Save Link As to save a local copy and then import it.

https://www.jeffersonscher.com/sumo/signingca1addonsmozillaorg_20190504.crt

Screenshot #1 shows the download method. Don't check any of the boxes, just click OK.

To import instead:

Go to the Options/Preferences page, Advanced section, Certificates panel, then click Certificate Manager. Make sure the Authorities tab is selected, then click Import. Find the file you downloaded and open it, then you should get the same dialog as in Screenshot #1, don't check any of the boxes, just click OK. Then you should see the new cert in the list in the Certificate Manager, as shown in Screenshot #2.

(2) Clear the time Firefox last re-verified

This will set Firefox up to check much sooner than it otherwise would check.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste xpi- and pause while the list is filtered

(C) Right-click the app.update.lastUpdateTime.xpi-signature-verification preference and click Reset on the context menu

Screenshot #3 illustrates the expected result.

(3) Restart Firefox

You can exit Firefox normally, then start it up again. In my tests, it took less than 60 seconds for Firefox to verify my extensions. Screenshot #4 is "before" and Screenshot #5 is "after."

Hopefully that will work for you.

Dear jscher2000, I am using Firefox 56.0.2 and this fix worked for me. I just trusted Jefferson and clicked on the link for step 1. I even clicked on it again as nothing appeared in my Downloads but it said the certificate was already there. Step 2 was a piece of cake. Stopped and restarted Firefox and, although the add-on logos did not appear immediately alongside the address bar, they soon appeared as before - and work. Thank you very much. W1shb0ne_Snap

''jscher2000 [[#answer-1218833|said]]'' <blockquote> Hi Matt, I was able to start testing in Firefox 52 ESR. When I install the hotfix extension, nothing happens, other than showing up on the Extensions panel of the Add-ons page. In the Browser Console, I see this message: TypeError: browser.experiments is undefined That means the main command of the extension doesn't run, so it's a dead end. ---- Next idea: ''Overview'' (1) Install the certificate the hotfix would have installed (2) Trigger Firefox to re-verify your extensions (3) Wait until it is back to normal ''Steps'' '''(1) Install certificate''' I extracted the certificate from my Firefox 66 and saved it on my webserver. Obviously if you don't trust me, you should not install it. Two possible methods: click to download through the certificate installer, or right-click > Save Link As to save a local copy and then import it. https://www.jeffersonscher.com/sumo/signingca1addonsmozillaorg_20190504.crt Screenshot #1 shows the download method. Don't check any of the boxes, just click OK. ''To import instead:'' Go to the Options/Preferences page, Advanced section, Certificates panel, then click Certificate Manager. Make sure the Authorities tab is selected, then click Import. Find the file you downloaded and open it, then you should get the same dialog as in Screenshot #1, don't check any of the boxes, just click OK. Then you should see the new cert in the list in the Certificate Manager, as shown in Screenshot #2. '''(2) Clear the time Firefox last re-verified''' This will set Firefox up to check much sooner than it otherwise would check. (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (B) In the search box above the list, type or paste '''xpi-''' and pause while the list is filtered (C) Right-click the '''app.update.lastUpdateTime.xpi-signature-verification''' preference and click Reset on the context menu Screenshot #3 illustrates the expected result. '''(3) Restart Firefox''' You can exit Firefox normally, then start it up again. In my tests, it took less than 60 seconds for Firefox to verify my extensions. Screenshot #4 is "before" and Screenshot #5 is "after." Hopefully that will work for you. </blockquote> Dear jscher2000, I am using Firefox 56.0.2 and this fix worked for me. I just trusted Jefferson and clicked on the link for step 1. I even clicked on it again as nothing appeared in my Downloads but it said the certificate was already there. Step 2 was a piece of cake. Stopped and restarted Firefox and, although the add-on logos did not appear immediately alongside the address bar, they soon appeared as before - and work. Thank you very much. W1shb0ne_Snap