ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Web Content high CPU load

  • 1 (رد واحد)
  • 2 have this problem
  • 17 views
  • آخر ردّ كتبه Timtak

more options

Starting Firefox with only one tab causes my CPU to spike and the fan to run at full speed.

In fact, it is the process "Web Content" that consumes 70-100% of my CPU power, while "Firefox" is still around 10%.

What's "Web Content" actually doing to require such a high CPU load? Is there a way to reduce the CPU usage? Is that a bug?

Firefox 58.0.1. Fedora 27 64-bit. Kernel 4.14.18.

Starting Firefox with only one tab causes my CPU to spike and the fan to run at full speed. In fact, it is the process "Web Content" that consumes 70-100% of my CPU power, while "Firefox" is still around 10%. What's "Web Content" actually doing to require such a high CPU load? Is there a way to reduce the CPU usage? Is that a bug? Firefox 58.0.1. Fedora 27 64-bit. Kernel 4.14.18.

All Replies (1)

more options

I think that Quantum splits up the task of rendering web pages between multiple processes on multiple cores of your processor. It means that Firefox is now the fastest browser (or at least faster than IE, Edge, Chrome and Safari) but it uses one heck of a lot of processing power. I guess that sharing the task of rendering inevitably results in some inefficiency, in addition to the overall increase in speed, too.

I was getting blue screens of death when other things used up a processor's capability to respond to sync calls.

Turning off Firfefox's hardware acceleration in settings makes Quantum as slow and peaceful as Firefox 56. That is what I have done. I don't need the speed. That said on other machines I don't need to turn off acceleration and FF runs at a blistering speed, so I guess that there is some BIOS / chipset driver or memory problem on the machine that gets BSOD.