X
Tap here to go to the mobile version of the site.

منتدى الدعم

input textbox backround color with Linux KDE dark theme

Posted

I'm having the same problem as this old support question. https://support.mozilla.org/en-US/questions/814083

Issue is that the answer seems outdated and when I search in the forums and MDN, if feel like I'm entering a rabbit hole.

Basically, I have Kubuntu 16.10 and Fire Fox 51.0a2 (2016-11-14) (64-bit). The KDE system theme is a dark one. Now what happens is that all my text boxes, in FF, are also dark. This makes it very hard to input text as most of the time the text is black or grey.

I looked into adding a userContent.css file in the chrome directory of my profile. Folder is not there, so I created it and the css file: input, textarea, select {

  color:#555 !important;
  background-color:#fff !important;
  -moz-appearance: none !important;

}

Found a chrome folder under /usr/lib/firefox/browser and copied the css file there. None of these did anything even after closing and reopening FF.

I do have "Use system colors" unchecked under Color Preferences...

I'm having the same problem as this old support question. https://support.mozilla.org/en-US/questions/814083 Issue is that the answer seems outdated and when I search in the forums and MDN, if feel like I'm entering a rabbit hole. Basically, I have Kubuntu 16.10 and Fire Fox 51.0a2 (2016-11-14) (64-bit). The KDE system theme is a dark one. Now what happens is that all my text boxes, in FF, are also dark. This makes it very hard to input text as most of the time the text is black or grey. I looked into adding a userContent.css file in the chrome directory of my profile. Folder is not there, so I created it and the css file: input, textarea, select { color:#555 !important; background-color:#fff !important; -moz-appearance: none !important; } Found a chrome folder under /usr/lib/firefox/browser and copied the css file there. None of these did anything even after closing and reopening FF. I do have "Use system colors" unchecked under Color Preferences...

Chosen solution

I now realize that the them affecting firefox is the GTK one. Not the KDE themes. I had the breze dark GTK theme active.

I just installed a, not dark, GTK theme and all seems well for the time being.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0

More Information

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process (content processes move into plugin-container.exe). One side effect users have noticed is that certain form elements, such as the options that drop from a select control, do not have the style assigned by the page. I really have no idea whether that issue is affecting your form controls, but could you take a look at this:

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process (content processes move into plugin-container.exe). One side effect users have noticed is that certain form elements, such as the options that drop from a select control, do not have the style assigned by the page. I really have no idea whether that issue is affecting your form controls, but could you take a look at this: ''Are you using e10s?'' You can check whether you have this feature turned on as follows. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s. ''If you are using e10s:'' To help evaluate whether that feature is causing this problem, you could turn it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autos''' and pause while the list is filtered (3) Double-click the '''browser.tabs.remote.autostart.2''' preference to switch the value from true to false ''Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart'' At your next Firefox startup, it should run in the traditional way. Any difference?

Question owner

Hi, thanks for the input! It was active and I disabled it. Now that problem is fixed, but things don't look quite right.

Check boxes, radios and the draggable corner of text areas are still dark.

there were 3 instances of browser.tabs.remote.autostart only the one ending in 2 was, initially, set to true.

Hi, thanks for the input! It was active and I disabled it. Now that problem is fixed, but things don't look quite right. Check boxes, radios and the draggable corner of text areas are still dark. there were 3 instances of browser.tabs.remote.autostart only the one ending in 2 was, initially, set to true.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Hmm, it now sounds like a Linux theme change, which is something I can't explore personally. But are styles you save in userChrome.css effective? If no style rules work, make sure your file is in the correct location: http://kb.mozillazine.org/UserChrome.css

Hmm, it now sounds like a Linux theme change, which is something I can't explore personally. But are styles you save in userChrome.css effective? If no style rules work, make sure your file is in the correct location: http://kb.mozillazine.org/UserChrome.css
James
  • Moderator
1595 solutions 11242 answers

There was a theme change with Firefox as of 46.0 as it requires GTk 3.4 or later to run so as a result you need GTK3 themes as GTK2 themes will not work.

There was a theme change with Firefox as of 46.0 as it requires GTk 3.4 or later to run so as a result you need GTK3 themes as GTK2 themes will not work.

Chosen Solution

I now realize that the them affecting firefox is the GTK one. Not the KDE themes. I had the breze dark GTK theme active.

I just installed a, not dark, GTK theme and all seems well for the time being.

I now realize that the them affecting firefox is the GTK one. Not the KDE themes. I had the breze dark GTK theme active. I just installed a, not dark, GTK theme and all seems well for the time being.