Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"A plugin is needed to display this content" even if Java is correctly installed and enabled

  • 4 replies
  • 14 have this problem
  • 143 views
  • آخر ردّ كتبه st1led

more options

Hi everybody, I'm experiencing problems with Java 8u20 and Firefox 32.0.2. Even tho the "Java(TM) 8 SE U20 Platform" plugin is installed and set to "Always activate", I have problems running it in some websites. Mind that if I go the usual Java test page (https://www.java.com/en/download/installed.jsp) I get the message that "You have the recommended Java installed (Version 8 Update 20).".

However, if I go to (https://www.bankid.no/Hjelp-og-nyttige-verktoy/Nyttige-verktoy/Test-din-BankID/), I first get the expected prompt "Do you want to run this application?", but then when I click Run a gray box appears with "A plugin is needed to display this content. Install plugin...". When I click on Install plugin, it tells me that Java Runtime Environment is available, but then on the following screen it tells me that "No plugins where installed" installed because Java Runtime Environment is suddenly "Not Available".

Any ideas? I tried to resintall both Firefox and Java, but to no avail. I call for some security-related problems, but I don't see anything like top bars asking me to activate the plugin, or rejected certificates. I also lowered the Java security level to "High" instead of "Very high" but that didn't help.

All Replies (4)

more options

Works for me on Linux with the Java 8u20 plugin.

  • BankID client version: 5.5.1

Did you get the various prompts from the Java plugin to accept the certificate and allow the application to run?

more options

Yes and no I would say. I only get this prompt, but when I click run the gray box "A plugin is needed to display this content" appears instead of the actual java applet. I remember that the popup used to be slightly different, for instance asking me to accept the certificate, but this one does not.

more options

I guess nobody has the slightest clue on why this is happening, right?

At this point, I think I tried pretty much whatever I could apart of the hugely time-expensive formatting the hard drive. Final hint (I checked the discussion and never mentioned it): I'm using Windows 8.1 x64 Enterprise. What hidden setting got broken?

more options

Breaking news!

Updating to Java 8u25 did not fix the issue.