ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox log me out of websites every few minutes?

  • 11 ردًا
  • 9 have this problem
  • 159 views
  • آخر ردّ كتبه cor-el

more options

I'm having a problem where I'm getting logged out of websites automatically every few minutes. It doesn't matter what the website is (Facebook, email, forums etc.) once I've logged in, after a few minutes of browsing I'll be logged out again. I've tried re-installing Firefox and have cleared my cookies/cache multiple times but it's still happening. I've been using Firefox for years and this is the first time anything like this has happened so I guess that it might be related to the latest update. Does anyone have any ideas?

الحل المُختار

A user who set Firefox to "never remember history" and as a result started up automatically in private browsing mode reported this problem. I'm not sure we figured how why they were affected -- i.e., has private browsing changed?

Not sure whether that is a factor in your case, since you did a Reset.

Read this answer in context 👍 1

All Replies (11)

more options

hello jonbev2303, do you happen do use any addons or external software that might interfere with the cookie handling in firefox?

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

As far as I'm aware, I haven't added any recently. I've attached a list of the current plugins I've got installed, I'm not sure if any of them could be the problem?

more options

could you also attach the contents of the "extensions" section - they are likelier to play a part in this problem. thank you...

more options

Thanks for your quick replies so far - I've attached a screenshot.

more options

does it make a difference when you reset firefox?

more options

Just tried that and I'm still having the same problem.

more options

What are the connection settings?

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

الحل المُختار

A user who set Firefox to "never remember history" and as a result started up automatically in private browsing mode reported this problem. I'm not sure we figured how why they were affected -- i.e., has private browsing changed?

Not sure whether that is a factor in your case, since you did a Reset.

more options

jscher2000, I think you've found the problem there. I have Firefox set to never remember history (and have done for some time now). I've just tried it with Firefox now remembering history and it seems to work with no problems. I'm not sure why this is the case, as I said it's never been a problem before.

For the time being I can get by with Firefox remembering history, but hopefully this issue will be solved in the next update. As the specific cause still seems unknown, I'll say that this has been solved. Thanks for all the suggestions!

more options

For other sites that don't have this problem, you can browse them in a private window using any of these methods:

  • right-click a link > Open Link in New Private Window
  • Ctrl+Shift+p to launch the private window, then click a bookmark or use the address/search bars

You will see a white-mask-on-purple-background near the minimize/maximize/close buttons for those windows.

more options

You can use an extension to get Private Browsing mode support per tab.