Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hierdie gesprek is in die argief. Vra asseblief 'n nuwe vraag as jy hulp nodig het.

package xpi, "corrupt" error

more options

I downloaded FireFTP add-on https://addons.mozilla.org/en-us/firefox/addon/fireftp/

But I hate the ugly blue seahorse icon in the toolbar. So I extracted the xpi, replaced the .ico and. png files, then repackaged it back as .xpi (first as zip, then renamed zip to xpi). I only did the content inside the top folder too, to clarify.

I get this error attached. Would appreciate help. Thanks.

Aangehegde skermkiekies

Gekose oplossing

Did you disable enforcement of extension signing in Firefox 41? Because repackaging the extension likely would invalidate the signature and maybe that is the meaning of the message.

But I do think I've run into that problem in older versions of Firefox. The workaround was to drag and drop the replacement parts onto the extension file and let the Zip software switch it out. I can't recall which Zip software I was using at the time.

Lees dié antwoord in konteks 👍 0

All Replies (6)

more options

Gekose oplossing

Did you disable enforcement of extension signing in Firefox 41? Because repackaging the extension likely would invalidate the signature and maybe that is the meaning of the message.

But I do think I've run into that problem in older versions of Firefox. The workaround was to drag and drop the replacement parts onto the extension file and let the Zip software switch it out. I can't recall which Zip software I was using at the time.

more options

You can no longer make changes to an extension as that will invalidate the signing. You will have to remove the META-INF folder to remove the signing data (manifest) and possibly disable signing in Firefox.

more options

"Did you disable enforcement of extension signing in Firefox 41"

I don't see this option anywhere. I'm running FF 41b4 version (64bit).

I also tried deleting the META-INF folder, repackaged and still getting the error when I drag/drop the extension into Firefox.

more options

Nevermind, found it in about:config section.

Change to false for xpinstall.signatures.required

Thanks

more options

i have this problem after re-pack xpi our extension. my singed xpi can work on firefox 40 and 39 but that doesn not work on firefox 41

more options

Hi tux-world, I see you have a separate question here where it probably makes sense to continue: https://support.mozilla.org/questions/1082284