Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why had firefox begun NOT deleting my cookies when I close firefox?

  • 7 uphendule
  • 8 zinale nkinga
  • 669 views
  • Igcine ukuphendulwa ngu jscher2000

more options

I have always had it set to delete my cookies and other information when I close Firefox, and it is still set to that. It has always cleared my information, and if I closed the browser windows I would have to retype in any usernames and passwords on sites - which is how I liked it. Now when I close my browser windows, and come back to open a new window, if I go to my email or to facebook or the like I am still logged in to the sites. Why? If I have to log off of each site on my own and clear my cookies on my own before I leave my computer, I will - but I wonder what changed?

All Replies (7)

more options

Are you closing all open tabs and windows before closing Firefox?

In case you are automatically reopening windows from the previous session via session restore:

  • Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"

Firefox stores cookies used in tabs that are currently open in the sessionstore.js file as part of saved session data, so those cookies will be restored if Firefox is closed without first closing these tabs.

You can set the browser.sessionstore.privacy_level pref to 2 (never) or 1 (non-HTTPS) on the about:config page to disable saving cookies via session restore.

The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values.

more options

cor-el: Does do not track prevent passwords from being stored as well? Or is it just the private window?

more options

Selecting the "do-not-track" setting will only make Firefox send a specific HTTP header ("Tell sites that I do not want to be tracked.": DNT=1) to a web server.

It is up to the server to do something with that request.

Extensions may extend the effect of do-not-track, so you need to check their options if you have such extensions installed.

more options

Firefox will automatically restore your previous session if it thinks it crashed (i.e., it did not shut down correctly). To see whether that is happening, you can change a setting so that instead of automatically restoring the session, Firefox display a list of windows and tabs. If you see that at startup, it's a sure sign that Firefox did not shut down correctly and we can focus on figuring out why that's happening.

Here's how to make the change:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box in that tab, type or paste sessions and pause while the list is filtered

(3) Double-click browser.sessionstore.max_resumed_crashes and change the 1 to a 0 (a zero) and OK that.

(4) You can close this tab now.

more options

By the way, now that Google always redirects to a secure (HTTPS) page, you can save a couple of milliseconds by updating your home page to the complete final URL https://www.google.com/ (if needed: How to set the home page).

more options

Did this behavior recently change? I'm finding that even my open tabs get their cookies deleted when I close Firefox despite having browser.sessionstore.privacy_level set to 0.

more options

Hi dojima, perhaps your problem is related to another factor, such as an add-on?? Could you start a new thread and include your system/add-on/settings information.

You can start a new question at the following link. Scroll down past the suggestions to continue with the form (I think it has 3 different screens). https://support.mozilla.org/en-US/questions/new/desktop/fix-problems