Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why doesn't firefox display properly icons in sites like github and font awesome?

  • 13 uphendule
  • 22 zinale nkinga
  • 196 views
  • Igcine ukuphendulwa ngu Dorjsuren

more options

I'm running firefox 20 on linux (opensuse 12.3) and this doesn't display properly some website... This look like:

Font awesome

(Font Awesome in Chromium properly displayed)

(Font Awesome in firefox not properly displayed)

Github

(Github in Chromium properly displayed)

(Github in firefox not properly displayed)

I thought the problem was the Unicode but I had changed the codification to UTF-8 and the problem persist Some suggestions for solve this. Thanks!

I'm running firefox 20 on linux (opensuse 12.3) and this doesn't display properly some website... This look like: Font awesome * https://www.dropbox.com/s/fyfvrjvsgp6wnyy/Font%20Awesome%2C%20the%20iconic%20font%20designed%20for%20Bootstrap%20-%20Chromium.png (Font Awesome in Chromium properly displayed) * https://www.dropbox.com/s/sc2tveddqrmqcz3/Font%20Awesome%2C%20the%20iconic%20font%20designed%20for%20Bootstrap%20-%20Mozilla%20Firefox.png (Font Awesome in firefox not properly displayed) Github * https://www.dropbox.com/s/89jpl8ezud83z1d/GitHub%20-%20Chromium.png (Github in Chromium properly displayed) * https://www.dropbox.com/s/wfbno5sg9iujp5h/GitHub%20-%20Mozilla%20Firefox.png (Github in firefox not properly displayed) I thought the problem was the Unicode but I had changed the codification to UTF-8 and the problem persist Some suggestions for solve this. Thanks!

Isisombululo esikhethiwe

Hello Again. I'm here for say sorry about post this issue here because the problem never wasn't firefox instead was my operative system (opensuse with Gnome 3.8) configuration that cause this bad behavior. The simple reason was the selection of region and language because the most generic language configuration for Spanish is [Spanish from Spain], but my selection was [Spanish from Colombia] this cause the bad behavior in firefox. I change the selection and the problem was solved.

Again sorry for post this issue as part of firefox.

Here firefox show properly the Unicode icon.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (13)

more options

Have you noticed issues with any other downloadable fonts? If you can't access any of them, check this first:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste gfx and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled is set to False, double-click it to set it back to the default value of True.


If downloadable fonts usually work but only occasionally do not, you might check whether any of your add-ons might be filtering them.


This particular downloadable font has caused some problems for others. Could you try the suggestions in the following thread: Characters codes are not showing correctly in my wesbite. I use other browser it works but her ein mozilla its not. Please help. Since the suggested keyboard shortcuts are for Windows, you might need to make a few changes along the way.

Okulungisiwe ngu jscher2000 - Support Volunteer

more options

Thanks jscher2000 for your reply. I checked the gfx.downloadable_fonts.enabled and is set to true. Then I turn off all my Add-on for avoid issues with down-loadable fonts and finally read the recommended thread and follow those instructions and I still have the same problem.

more options

Do you see any error messages in the Error Console (Firefox/Tools > Web Developer; Ctrl+Shift+J) or Web Console (Firefox/Tools > Web Developer; Ctrl+Shift+K) related to downloading this font?

You need to reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files from the server.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

I don't see any error message in the Web console, only warning for CSS properties and various GET request completed successful (some css, js, json, gif and apparently any web method)

more options

Did you try Firefox Safe Mode?

Make sure that you allow pages to choose their colors in Firefox.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"
more options

Yes I tried the safe mode of firefox and be sure that "Allow pages to choose their own colors, instead of my selections above" options was selected and the problem still persist.

more options

Do you have problems with downloable fonts on other websites like the Google webfonts?

more options

Yes. I have exactly this problem.

more options

Try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

I have created a new profile for test and the problem persist. I entered to google fonts web site and the result is the same.

I really appreciate you effort cor-el and I hope that it issue can be resolved.

Thank you very much.

more options

Isisombululo Esikhethiwe

Hello Again. I'm here for say sorry about post this issue here because the problem never wasn't firefox instead was my operative system (opensuse with Gnome 3.8) configuration that cause this bad behavior. The simple reason was the selection of region and language because the most generic language configuration for Spanish is [Spanish from Spain], but my selection was [Spanish from Colombia] this cause the bad behavior in firefox. I change the selection and the problem was solved.

Again sorry for post this issue as part of firefox.

Here firefox show properly the Unicode icon.

Okulungisiwe ngu jarneygm

more options

I wonder why the country affects the display (or download) of the font? Firefox sends a header to websites indicating which languages are preferred. Could that be it? Hmmm...

more options

@font-face {

 font-family:'FontAwesome';
 src:url('../font/fontawesome-webfont.woff');
 src:url('../font/fontawesome-webfont.eot?#iefix') format('embedded-opentype')
   url('../font/fontawesome-webfont.ttf') format('truetype');
 font-weight:normal;
 font-style:normal

}

i solved this problem my IIServer,

fontawesome-webfont.eot changed to fontawesome-webfont.woff