Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I selected "remember password for this site", and now I do not want the password remembered, so how do I reverse my error?

  • 4 uphendule
  • 1 inale nkinga
  • 484 views
  • Igcine ukuphendulwa ngu Duey

more options

I selected "remember password for this site", and now I do not want the password remembered, so how do I reverse my error? I have Windows 7. I can't find "Tools" in Firefox.

All Replies (4)

more options
  • Press the F10 key or tap the Alt key to bring up the "Menu Bar" temporarily if the menu bar is hidden.
  • Use "Firefox > Options" instead of "Tools > Options" if the menu bar is hidden.

Use these steps to remove saved (form) data from a drop down list:

  1. Click the (empty) input field on the web page to open the drop down list
  2. Highlight an entry in the drop down list
  3. Press the Delete key (on Mac: Shift+Delete) to remove it.

You can remove saved Password(s) here:

  • Firefox/Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"
more options

How do I turn on my Remember passwords for sites: it is grayed out ?

more options

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Instead of Tools > Options use:

  • Mac: Firefox > Preferences
  • Linux: Edit > Preferences
  • Windows: Firefox > Options

Press F10 if the menu bar is hidden on Windows and Linux or use "Firefox > Options/Preferences"

more options

Thanks it was driving me nuts, I do not remember ticking Private Browsing mode.