Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Outlook Express dropping recipient address with mailto:

  • 7 uphendule
  • 1 inale nkinga
  • 6 views
  • Igcine ukuphendulwa ngu greengofer

more options

Sites with mailto: links are not passing through the recipient address to Outlook Express with Firefox 5. This problem has persisted for at least 4 months now and a fix was promised months ago. I am running 5.0.1 on a PC with Windows XP. Outlook Express does execute, but the new message window does not open and of course nothing is filled in.

Isisombululo esikhethiwe

msimn.exe is Outlook Express.

As far as I know Outlook Express has been replaced by Windows Live Mail even if you just use it like Outlook Express on your computer not on a web page. But I had been on Windows 2000 and am now on Windows 7 myself. You are on XP.

When I looked at mailto: mine shows "Windows Live Mail (default)" and the details shows "WinMail.exe" as selected, and Yahoo Mail, and GMail. And dialog comment for the selected -- "This application is located at: C:\Program Files\Windows Mail\WinMail.exe"

Most things seem to be found by dumb luck, even luckier is when what you find is something that you are actually looking for. Someone else is surely going to have the same problem some day -- please mark question as solved so anyone looking for answers to the same problem will know there is a solution available. I doubt that I would have looked past the default selection. Do you really show Outlook Express on the Title Bar or do you show Windows Live Mail (or something slightly different, I don't remember what was in-between).

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

mailto: links not being passed to Outlook Express

Could you post the webpage, and the reference to the problem and where a solution in the works. Is it a problem only with XP because I've never run into such a problem. If people had to adjust their settings for it to work then use of mailto would not be practical to use at all.

The only problem I've had was with the use of Redirect remover but that was a long time ago, the problem could be bypassed and it was fixed by the extension author. Does the problem happen in Safe Mode if it doesn't then that would mean that an extension is probably the cause.


Safe Mode: bring up in safe mode one time, when you do so do not check-mark any of the items (they are certainly not safe). Help ("Alt+H") > "Restart with Add-ons disabled". If there is not problem then it is almost certainly an extension.

Help (Alt+H) --> Restart with Add-ons disabled (this is Firefox Safe Mode -- Fx4 has made this easier)

Okulungisiwe ngu David McRitchie

more options

It happens with all web pages. If the page has a mailto: link and I click on it, Outlook Express opens to the main screen. It does not initiate a new message and obviously can't fill in the recipient. This is NOT the case with Outlook which is functioning as it should. Similarly, if I use Internet Explorer with the same web pages, mailto: functions properly.

My conclusion is that Firefox 5 (I did not have this problem until I upgraded from FF 4) is not passing the correct command string to Outlook Express. I have been reporting this problem for more than 4 months and it's as if I'm the only person experiencing this issue. Still seems to me that it's a FF 5 issue even if it's something in my settings. I have yet to receive any direction from anyone on this one.

more options

Did you try it in Safe Mode.

Could you post the webpage that you have a problem with.

Do you have a problem with the mailto at the bottom of following page?

http://dmcritchie.mvps.org/firefox/firefox-problems.htm#mailto

Okulungisiwe ngu David McRitchie

more options

Yes - I have the same issue with the e-mail at the bottom of the webpage you specified. Here's the thing and I don't know why. When I click on ANY mailto: link on ANY website displayed in FF5, all that gets passed is run the .exe for outlook express without passing any other parameters such as recipient or subject.

I have been blaming FF5 since I did not have the problem with FF4. However, I have been around the cyber block more than a few times. Maybe it is a microsoft problem. Maybe there's a new dll or other "update" that causes a problem with FF5 and OE in order to push me away from Mozilla. Something like what they did with Bing, blocking all other search engines from the Explorer menu bar. Sounds like something they would do.

more options

Are you ready for this? I solved my problem. Dumb luck I'm afraid. I went to Tools>Options>Applications and scrolled down to mailto: It was set to "Use Outlook Express". But then I clicked on Application Details. In addition to the Google and Yahoo details was another line. msimn.exe. Apparently this line was overriding the defaults for Outlook Express and simply running the executable. Once I removed that line, it worked fine. How it got there, I do not know - I certainly didn't put it there. So all is as it should be. We can beat our heads against the wall trying to figure out what caused that line to appear if we'd like. Go figure!

more options

Isisombululo Esikhethiwe

msimn.exe is Outlook Express.

As far as I know Outlook Express has been replaced by Windows Live Mail even if you just use it like Outlook Express on your computer not on a web page. But I had been on Windows 2000 and am now on Windows 7 myself. You are on XP.

When I looked at mailto: mine shows "Windows Live Mail (default)" and the details shows "WinMail.exe" as selected, and Yahoo Mail, and GMail. And dialog comment for the selected -- "This application is located at: C:\Program Files\Windows Mail\WinMail.exe"

Most things seem to be found by dumb luck, even luckier is when what you find is something that you are actually looking for. Someone else is surely going to have the same problem some day -- please mark question as solved so anyone looking for answers to the same problem will know there is a solution available. I doubt that I would have looked past the default selection. Do you really show Outlook Express on the Title Bar or do you show Windows Live Mail (or something slightly different, I don't remember what was in-between).

more options

If I go to Tools>Options>Applications in FF5 with my OS (Win XP SP3) and I scroll down to Mailto: and view the pulldown menu what I see is Use Outlook Express (default), GMail, Yahoo! Mail, and other. If I select application details, I get the web locations for both GMail and Yahoo! Mail. When it was not working, I also had an entry of msimn.exe (the Outlook Express executable), deleting that fixed my problem. I do not have an entry for Windows Live Mail. I suppose I could add it under "other", but I suspect I'd be asking for trouble. Problem marked as "Solved". Thanks.