Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I need 3.5 because other versions are incompatable with the LMS

  • 2 uphendule
  • 1 inale nkinga
  • 15 views
  • Igcine ukuphendulwa ngu Carol.Allen

more options

The university is running BlackBoard Vista as the LMS. Firefox 3.5 is the supported version. Other versions are not supported. How can I get the 3.5 version of firefox to install on my computer? (OS Windows 7).

The university is running BlackBoard Vista as the LMS. Firefox 3.5 is the supported version. Other versions are not supported. How can I get the 3.5 version of firefox to install on my computer? (OS Windows 7).

Isisombululo esikhethiwe

All Replies (2)

more options

Isisombululo Esikhethiwe

Install Portable Firefox 3.5.x to your hard drive.
http://portableapps.com/apps/internet/firefox_portable/localization#legacy35