X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I get the bookmark drop-down button to display on the nav bar instead of the bookmark bar?

Kuphostiwe

I just updated to Firefox 4 and most things are great. My problem is that it seems that if you choose to display the bookmarks toolbar, then that becomes the only place you can put the bookmarks drop-down button (the one that is normally next to the home button on the nav bar). If I right click and choose customize, then the bookmark button automatically switches back to the nav bar where I want it - but as soon as I click done, it moves back to the bookmarks toolbar. I don't want to get rid of either the toolbar or the button - I just want to move the button back to the nav bar.

I just updated to Firefox 4 and most things are great. My problem is that it seems that if you choose to display the bookmarks toolbar, then that becomes the only place you can put the bookmarks drop-down button (the one that is normally next to the home button on the nav bar). If I right click and choose customize, then the bookmark button automatically switches back to the nav bar where I want it - but as soon as I click done, it moves back to the bookmarks toolbar. I don't want to get rid of either the toolbar or the button - I just want to move the button back to the nav bar.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • PopCap Games Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • iTunes Detector Plug-in
  • DivX Web Player version 2.0.3.4
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60129.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Google Update
  • Version 1.1.4, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Eminye Imininingwane

twalker 4 izisombululo 49 izimpendulo
Kuphostiwe

Right click on the nav bar and choose customize. Then the bookmarks icon will be a little book with a star on it. At first it will seem odd because the icon is on the nav bar in customize mode. Just click and drag it anywhere you want.

Right click on the nav bar and choose customize. Then the bookmarks icon will be a little book with a star on it. At first it will seem odd because the icon is on the nav bar in customize mode. Just click and drag it anywhere you want.

Umnikazi wombuzo

The problem is, I can drag the button wherever I want in customize mode, but then as soon as I click done on the customize window the button moves back to the bookmark toolbar.

The problem is, I can drag the button wherever I want in customize mode, but then as soon as I click done on the customize window the button moves back to the bookmark toolbar.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 izisombululo 40290 izimpendulo
Kuphostiwe

That particular Bookmarks button is tied to the state of the Bookmarks Toolbar. It is on the Bookmarks Toolbar when it is showing, and when the BTB is hidden that button will show where you placed it in the Customize mode.

That particular Bookmarks button is tied to the state of the Bookmarks Toolbar. It is on the Bookmarks Toolbar when it is showing, and when the BTB is hidden that button will show where you placed it in the Customize mode.
imMichael 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Unfortunately, when you switch to fullscreen mode (e.g. with F11), the bookmarks toolbar disappears taking the bookmarks button with it(!). I would expect the button to actually appear in it's designated place (nav bar) when the toolbar is not available, instead.

Interestingly, when the bookmarks toolbar is hidden in the normal mode, the bookmarks button does appear in the nav bar both, in the normal and fullscreen modes.

See screen-shots from my desktop for illustration. The 2nd image should look like the 4th, but doesn't. I left the position setting for the bookmarks button unchanged between the pictures.

Unfortunately, when you switch to ''fullscreen'' mode (e.g. with F11), the bookmarks toolbar disappears taking the bookmarks button with it(!). I would expect the button to actually appear in it's designated place (nav bar) when the toolbar is not available, instead. Interestingly, when the bookmarks toolbar is hidden in the ''normal'' mode, the bookmarks button does appear in the nav bar both, in the ''normal'' '''and''' ''fullscreen'' modes. See screen-shots from my desktop for illustration. The 2nd image should look like the 4th, but doesn't. I left the position setting for the bookmarks button unchanged between the pictures.
nathanm 0 izisombululo 3 izimpendulo
Kuphostiwe

I have the same problem in MacOS X. The tabs on top feature is great, except part of their benefit is lost by the window title bar and the ever-present MacOS menu bar. I was hoping Firefox 4 in full-screen mode would alleviate those problems. The good news is that it does. I can move the mouse up, indiscriminately, to the top of the screen, and the only clickable UI elements are the tabs. The bad news is the bookmarks toolbar disappears, and there's no option to display it. Even the bookmarks pull-down menu disappears. There are extensions to get around this, like sidebars, but this should be fixed in Firefox itself.

The only items in the full-screen context menu are to "Hide Toolbars" and exit full screen. There should be options to show more toolbars, especially since the hide command is already plural.

There's also a better way to use Firefox 4 in windowed mode. Nothing can be done about the MacOS menu bar, but the window title bar is redundant and unnecessary. Each website's title is already displayed on the tab itself. Version 10 of iTunes switched from a horizontal row of colored buttons to a vertical column. Could Firefox do the same and get rid of the window title bar? At least make it an option. Some people didn't like the change in iTunes, but many websites explain how to change it back.

I have the same problem in MacOS X. The tabs on top feature is great, except part of their benefit is lost by the window title bar and the ever-present MacOS menu bar. I was hoping Firefox 4 in full-screen mode would alleviate those problems. The good news is that it does. I can move the mouse up, indiscriminately, to the top of the screen, and the only clickable UI elements are the tabs. The bad news is the bookmarks toolbar disappears, and there's no option to display it. Even the bookmarks pull-down menu disappears. There are extensions to get around this, like sidebars, but this should be fixed in Firefox itself. The only items in the full-screen context menu are to "Hide Toolbars" and exit full screen. There should be options to show more toolbars, especially since the hide command is already plural. There's also a better way to use Firefox 4 in windowed mode. Nothing can be done about the MacOS menu bar, but the window title bar is redundant and unnecessary. Each website's title is already displayed on the tab itself. Version 10 of iTunes switched from a horizontal row of colored buttons to a vertical column. Could Firefox do the same and get rid of the window title bar? At least make it an option. Some people didn't like the change in iTunes, but many websites explain how to change it back.

Umnikazi wombuzo

Well, the-edmeister's answer is basically what I was afraid of - which is that this problem is in fact a design choice by Mozilla, not a bug or simply a setting I was missing. Hopefully in a future version this will become customizable again.

Well, the-edmeister's answer is basically what I was afraid of - which is that this problem is in fact a design choice by Mozilla, not a bug or simply a setting I was missing. Hopefully in a future version this will become customizable again.
cyfroice 0 izisombululo 1 izimpendulo
Kuphostiwe

I have found a solution to this problem that seems to work very well. Install this Bookmark Extension and in the options select: "All Bookmark Items".

It then places a button in your toolbar that works just like the Bookmarks button.

I have found a solution to this problem that seems to work very well. Install this [https://addons.mozilla.org/en-US/firefox/addon/bookmarks-menu/ Bookmark Extension] and in the options select: "All Bookmark Items". It then places a button in your toolbar that works just like the Bookmarks button.
nathanm 0 izisombululo 3 izimpendulo
Kuphostiwe

Impendulo Ewusizo

It's a stopgap measure, but it still doesn't solve the problem. This needs to be fixed in Firefox itself, and allow the toolbar to display also. This add-on only includes a substitute for the Bookmarks pull-down menu.

It's a stopgap measure, but it still doesn't solve the problem. This needs to be fixed in Firefox itself, and allow the toolbar to display also. This add-on only includes a substitute for the Bookmarks pull-down menu.
cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

You can use code in userChrome.css in the chrome folder in the Firefox profile folder to make that button visible all the time.
See http://kb.mozillazine.org/Editing_configuration

Add code to userChrome.css below the @namespace line.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#bookmarks-menu-button-container { display:-moz-box !important; }

Help > Troubleshooting Information > Profile Directory: Open Containing Folder (-> chrome folder)

You can use code in userChrome.css in the chrome folder in the Firefox profile folder to make that button visible all the time.<br /> See http://kb.mozillazine.org/Editing_configuration Add code to [http://kb.mozillazine.org/UserChrome.css userChrome.css] below the @namespace line. <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #bookmarks-menu-button-container { display:-moz-box !important; } </nowiki></pre> ---- Help > Troubleshooting Information > Profile Directory: Open Containing Folder (-> chrome folder)
nathanm 0 izisombululo 3 izimpendulo
Kuphostiwe

I just installed the 4.0.1 update, and the bug is still there.

I just installed the 4.0.1 update, and the bug is still there.
Bad.Designers 0 izisombululo 1 izimpendulo
Kuphostiwe

The suggestion from cyfroice is the best solution.

This is the only thing approaching a solution to the problem, until the designers fix this gaff.

They design a menu that cascades to the right, and place it on the right, brilliant. Then they only make the menu appear based on conditions of an unrelated menu, true genius.

The suggestion from cyfroice is the best solution. This is the only thing approaching a solution to the problem, until the designers fix this gaff. They design a menu that cascades to the right, and place it on the right, brilliant. Then they only make the menu appear based on conditions of an unrelated menu, true genius.

Okulungisiwe ngu Bad.Designers