Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google ReCAPTCHA is not working on all websites

  • 6 uphendule
  • 3 zinale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options

Google ReCaptcha is not working on literally all websites. Once I click on checkbox "I'm not a robot" It gets stuck on infinite loop. Although working on Mac OS in Firefox and Chrome or any other browsers. The issue is primarily with Windows version

I already tried clearing cookies, cache, disabling Tracking Protection, adding sites to DNS white list

Environment: OS Windows 11 Version 23H2, Firefox 125.0.3 For testing used: https://www.google.com/recaptcha/api2/demo

Google ReCaptcha is not working on literally all websites. Once I click on checkbox "I'm not a robot" It gets stuck on infinite loop. Although working on Mac OS in Firefox and Chrome or any other browsers. The issue is primarily with Windows version I already tried clearing cookies, cache, disabling Tracking Protection, adding sites to DNS white list Environment: OS Windows 11 Version 23H2, Firefox 125.0.3 For testing used: https://www.google.com/recaptcha/api2/demo
Ama-screenshot ananyekiwe

Okulungisiwe ngu Maxim L

All Replies (6)

more options

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Does it still happen in Troubleshoot Mode?

Helpful?

more options

Same issue! randomly started happening yesterday, spent hours and literally tried everything. It works fine on microsoft Edge! Please tell me there's a solution for this.

Helpful?

more options

Temporary fix but good work around for now- As another user instructed, download the following extension. User-Agent Switcher by Erin Schlarb Set the default to windows/chrome 123 Recaptcha all work normally now. Looks like firefox is getting blocked somehow.

Helpful?

more options

Like you posted, only Firefox with a Windows user agent seems to be affected. It works for me with a MAC user agent and with a Linux user agent.

Helpful?

more options

I have the same issue. The user-agent switcher solution doesn't help. The problem doesn't happen on Chrome browsers.

Helpful?

more options

Google has fixed this issue, so you no longer need the extension or about:config to override the user agent and can use your default user agent.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.