Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

MS Firefox not playing video that used to work

  • 5 uphendule
  • 0 zinale nkinga
  • 10 views
  • Igcine ukuphendulwa ngu jonzn4SUSE

more options

Video on https://www.abbeyroad.com/Crossing is suddenly unable to be played after to last Firefox update!! This has happened several times in the past but after 2 or 3 days it suddenly will start working again!!! It's been over a week this time and no resolution yet! Note following LARGE ROTATING X is: "The media could not be loaded, either because the server or network failed or because the format is not supported." Same note as in the past but eventually disappears and video works just fine. The video is a live shot of the Abbey Studio's Crosswalk (ie, the one shown on the cover of a Beetles Album years ago).

Video on https://www.abbeyroad.com/Crossing is suddenly unable to be played after to last Firefox update!! This has happened several times in the past but after 2 or 3 days it suddenly will start working again!!! It's been over a week this time and no resolution yet! Note following LARGE ROTATING X is: "The media could not be loaded, either because the server or network failed or because the format is not supported." Same note as in the past but eventually disappears and video works just fine. The video is a live shot of the Abbey Studio's Crosswalk (ie, the one shown on the cover of a Beetles Album years ago).

All Replies (5)

more options

In the future, a screenshot would be helpful. Is this what you're seeing? see screenshot I think I'm getting it because my current OS is a Alpha version. Let me get on another computer. Are you on a laptop or desktop? If desktop, is it DIY? Provide the make and model of you computer if it's not DIY. What graphics card, are your drivers current? Can you update to 120.0.1 and see if it helps?

Okulungisiwe ngu jonzn4SUSE

Helpful?

more options

Looks like a site issue. I have the same issue in Chrome. see screenshot

Helpful?

more options

Abbey Road Studios uses EarthCam which reports "This camera is unavailable" on Firefox and Chrome.

https://www.earthcam.com/world/england/london/abbeyroad/?cam=abbeyroad_uk

Helpful?

more options

Screen shot attached. In the past when this occurs after a Firefox update, it usually clears up in a few days but hasn't this time.

Don't know how go add screen shot. I have a .docx print file of the screen shot BUT it won't upload!!!

Helpful?

more options

It doesn't matter. The issue with with earthcam as zeroknight explained. Also, for screenshot you should use the snipping tool in windows.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.