Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Autoplay is set to allow all video/audio to play, yet twitch never autoplays the audio.

  • 10 uphendule
  • 0 zinale nkinga
  • 45 views
  • Igcine ukuphendulwa ngu scyris99

more options

So I have it set globally to allow all websites to autoplay video and audio, however when I go to twitch.tv, the audio does not work, the video plays fine, but the audio does not, I have to pause the stream and hit play again to get audio to work, refreshing the page does not work. Only does this on twitch.tv no where else. I've tried several things. Even a completly new profile nothing seems to fix it, and it does it with or without addons. Only way to get it to play properly is in troubleshooting mode even on a fresh profile. Any idea what this can be because its really annoying and it started about a month ago randomly after a firefox update and it just has not gone away since. troubleshooting mode seems to disable whatever is the culprit even on a fresh profile. Any help would be apprecated as this issue has been persisting and I just cannot seem to fix it permamently.

So I have it set globally to allow all websites to autoplay video and audio, however when I go to twitch.tv, the audio does not work, the video plays fine, but the audio does not, I have to pause the stream and hit play again to get audio to work, refreshing the page does not work. Only does this on twitch.tv no where else. I've tried several things. Even a completly new profile nothing seems to fix it, and it does it with or without addons. Only way to get it to play properly is in troubleshooting mode even on a fresh profile. Any idea what this can be because its really annoying and it started about a month ago randomly after a firefox update and it just has not gone away since. troubleshooting mode seems to disable whatever is the culprit even on a fresh profile. Any help would be apprecated as this issue has been persisting and I just cannot seem to fix it permamently.

All Replies (10)

more options

Cannot edit so posting it here, Apparently not even troubleshooting mode gets the audio to autoplay correctly on twitch.tv

more options

It works for me.

What changed between your initial post and your edit that could have caused it to stop working in Troubleshoot Mode? Is it intermittent?

Does it still happen with low latency mode disabled (video settings (gear icon) > Advanced > Low Latency)?

more options

zeroknight said

It works for me. What changed between your initial post and your edit that could have caused it to stop working in Troubleshoot Mode? Is it intermittent? Does it still happen with low latency mode disabled (video settings (gear icon) > Advanced > Low Latency)?

Nothing changed I've even tried this on a fresh profile and still had the same issue, It just started happening one day after firefox updated and it just seems to not be going away. I don't got a issue in Edge or Chrome, just firefox.

more options

Anything relevant-looking media messages in the Web Console ?

more options

You can find "Edit this question" under the "Question Tools" menu in the sidebar (you may have to scroll to the top). For a reply, "Edit this post" is in the three-dot menu next to a reply.

more options

cor-el said

Anything relevant-looking media messages in the Web Console ?

Not that I can see, I don't see any errors about the audio or video that I can see.

more options

You said it worked in Troubleshoot Mode initially, does it still sometimes work in Troubleshoot Mode?

more options

zeroknight said

You said it worked in Troubleshoot Mode initially, does it still sometimes work in Troubleshoot Mode?

Sometimes it does sometimes it doesn't, I know that doesn't help much. Like I said this issue started after a firefox update, and I didn't change any addon's or anything. I'll see if it works again if I disable every addon. Nope still won't autoplay the audio even thou its set both globally AND on twitch to autoplay video and audio. So whatever the problem is, its not caused by a addon of any kind, as I still have the issue even with all of them disabled.

Okulungisiwe ngu scyris99

more options

It sounds like a more general audio issue unrelated to autoplay settings. Try updating your audio drivers from the manufacturer's site.

You can test older Firefox versions with mozregression to see if this is a recent breakage and identify when it first appeared.

more options

Weird thing, is, the sound does work fine after I pause then hit play on the stream on twitch, and it also doesn't works fine on clips, its just live streams where the issue is, and its only on twitch, i've tried youtube and even Kick and do not have this issue, so its specifically something with twitch I think. I've also not had any audio issues in firefox anywhere else, again its just with twitch. That seems oddly specific to have just a issue there and no where else.