Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox search suggestions won't turn off

  • 2 uphendule
  • 1 inale nkinga
  • 43 views
  • Igcine ukuphendulwa ngu toegelmarkus

more options

Dear all, I have unchecked all the boxes in "Settings/Search/Search Suggestions" and disabled history for the search engine and yet Firefox still displays search suggestions in the address bar. They even have a small header called "Firefox Suggest". How can I turn this off? Thanks for your help, Markus

Windows 11 Home 22H2 FF 118.0.1 (64-bit)

Default search engine is Google

Dear all, I have unchecked all the boxes in "Settings/Search/Search Suggestions" and disabled history for the search engine and yet Firefox still displays search suggestions in the address bar. They even have a small header called "Firefox Suggest". How can I turn this off? Thanks for your help, Markus Windows 11 Home 22H2 FF 118.0.1 (64-bit) Default search engine is Google

Isisombululo esikhethiwe

Dear zeroknight,

I just found out that the Address Bar options are not displayed in my Settings/Privacy & Security tab. I had to refresh Firefox and now they are there. Very strange indeed. However, unchecking Bookmarks solved the problem. Thanks for your help, the issue is now resolved! Best, Markus

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

"Firefox suggest" items are not suggestions provided by the default search engine.

Disable everything in Privacy & Security > Address Bar.

more options

Isisombululo Esikhethiwe

Dear zeroknight,

I just found out that the Address Bar options are not displayed in my Settings/Privacy & Security tab. I had to refresh Firefox and now they are there. Very strange indeed. However, unchecking Bookmarks solved the problem. Thanks for your help, the issue is now resolved! Best, Markus