Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Turn off all threading Thunderbird 115+

  • 24 uphendule
  • 46 zinale nkinga
  • 3650 views
  • Igcine ukuphendulwa ngu m2uant73

more options

Answers to the question "how to turn off all threading in Thunderbird" no longer work with changed menu structures in Thunderbird 115. What is the answer to this question now?

Answers to the question "how to turn off all threading in Thunderbird" no longer work with changed menu structures in Thunderbird 115. What is the answer to this question now?

Isisombululo esikhethiwe

My guess is you are using the hamburger menu. Use the menu bar to set this.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (20)

more options

To my awareness, what I originally posted some months ago is still correct:

This is the official (to my knowledge) documentation. Well worth the read https://support.mozilla.org/en-US/kb/message-threading-thunderbird

Here is my own documentation on threading, duplicating the above, but it may help: You need to highlight each folder and click View>sort by>unthreaded. If this applies to just a few folders, just repeat the process as necessary. If you have many folders or plan to add many new folders, you may wish a different approach, below:

More info: To change default for *new* folders, In config editor, you can change default that applies to NEW folders you set up: mailnews.default_view_flags 0=unthreaded

Config editor is available at Tools>settings>general and scroll to bottom right.

 ------------

To set many *existing* folders, follow these steps: (I creates a crude video that walks through the steps at

   https://davidkirk.org/SettingDefaultFolderView.mp4  that demonstrates the following steps:
   First, highlight a folder that you have set to unthreaded	
   In the Message List view, in the column header, on the far right, open the options button that shows    
    context menu. :
   At the very bottom is the option:
   -> "Apply current view to..."
   -> "Folder and its children..."
   -> Hover over an account
   -> In the next menu don't select a folder. Instead select the account name itself.

ALSO, for future installations of Thunderbird, 
- install Thunderbird and exit prior to setting up accounts
- create a simple text file with name of user.js with these lines: 
     // Set default threading to UNthreaded  ###   <== this line is optional, just for documentation
     user_pref("mailnews.default_view_flags", 0);
- copy the user.js file into the profile
- now, when you start Thunderbird, unthreading will be the default. Problem solved. 

more options

Thanks. But "View>sort by>unthreaded" doesn't work with 115+. There is no "sort by" submenu under "View". And none of the submenus that do exist are any help.

more options

Please share more info on your version. My 115.3 has view>sort by>unthreaded.

more options

Isisombululo Esikhethiwe

My guess is you are using the hamburger menu. Use the menu bar to set this.

more options

Thanks, I got there in the end. I've habitually used the hamburger menu - in previous versions of Thunderbird it contained all the same elements as the menu line. Other defaults for a new Thunderbird 115 installation meant that things described in your instructions are not visible. Ironically, I now see something much more like the earlier Thunderbird. And thankfully no threads!

more options

Thanks for the update. Personally, I think it's not good design to have the two menus not in sync, but maybe the intent was to provide only major functions.

more options

I have recently been updated to V115.4.1 and have the unwanted thread problem. I have followed the instructions above View / Sort by / Unthreaded I have tried with the threads column present and deleted but the problem persists The threads disappear initially but then come back the next day when I start TB up again, Sometime it even comes back during the day, possibly when a new email comes in that links to a previous email. I am just trying to do it for my Inbox at the moment, and would like my unthreaded choice to be PERMANENT.

more options

Puzzling, as no one else has reported that. All I can surmise is that all folders in all accounts were not reset.

more options

Has worked correctly for a few days, perhaps it needed a restart for it to become effective? Glad to have it solved.

more options

I am pleased that it's now working for you. :)

more options

I have the same problem for a few versions now, on multiple machines.

Setting the mailnews.default_view_flags doesn't change the behavior for new folders, same goes for applying the non-threaded settings to all folders, as any new folder always has the threaded and starred columns active.

I'd try a new profile if I hadn't tried it on different machines already.

more options

I suggest you check settings again. The mailnews setting to 0 does work and has been tested with many accounts.

more options

Nope, sorry.

Is there any other setting that overrides this?

I am using userchrome quite a bit...

more options

I tried to find the menu options described and the only thing I could see was "thread" in the menu button (the not-a-hamburger, in the top-right of the folder window), which really seem to do nothing but adding a column to the left with (I guess?) is a "threaded" icon. This does not "unthread" messages if unticked. Threaded messages are extremely frustrating: it is literally impossible to see at a glance if there is a new email tucked into the thread, as it is out of sight. .

      • I am missing important emails because this awful feature hides the emails I need to read.***

. The posted instructions DO NOT WORK on Thunderbird 115.6.0

more options

First: How does one know if using "hamburger" menu or not? Second: When I click on a folder, I don't get any 'View' or ANY options. I click a folder, and nada. 115.6.0 I clicked (or maybe R-clicked) the 'Thread' column and hit the Delete key and now it's gone, and I'm seeing no threading now--no idea if this will continue. Hope so. Having Threading ON by default is, IMO, very much the wrong way to go.

more options

[deleted]


never mind, instructions weren't clear.

Okulungisiwe ngu mikirby

more options

By chance, I seem to have discovered how to turn off threading of conversations: At the top-right of the screen is a button labelled "Quick Filter" and immediately to its right is what looks like a film strip. Click on that "film strip" and then "sort by". In the bottom section of the menu which pops out, are the "threaded/unthreaded/sort by group" options. Clicking on "unthreaded" fixes this problem. This unthreads all conversations.

more options

But that is just a sort by choice. I don't want threads at all. Can't say the number of important responses I have not seen because it went into the thread of a previous email which was some 65 emails down from my sort choice of newest to oldest.

I tried some of the fixes some work, some don't. Then an update comes out and I am back to the threads. No idea why you folks have this thing turned on. Please do stop assuming you have any idea what we need in our work lives. The newest things the 20 somethings are enamored of aren't necessarily what people who work for a living need.

Going back to try AGAIN to correct the issue. If I sound harsh it might be because of the tone of the guy who said its only you having the issue. For everyone who actually reports it and takes the time to type into the support system there are many more, I'm sure, who just give up and stop using your product and say nothing.

more options

"Me too"

Threading could actually be quite helpful, but it's a disaster because new emails are lumped into a thread which is folded away by default, and the bold styling used to indicate unread messages is not shown on the thread (it seems to use a barely perceptible underscore, but once you start receiving more than 10 emails a day you just won't be able to locate most of your unread emails any more)

This wouldn't be a problem if there was a preference... but I've reset the setting to "Not threaded" many times and it keeps resetting every day like a virus!

Thunderbird is a wonderful product but please can the preference bug be fixed and/or upgrade the threading UI so that any thread with an unread message in it is shown in the position that message would appear in the view, and in bold. i.e. provide a consistent UX for unread messages in both threaded and unthreaded views.

more options

I'm wondering if anyone has found a solution for this issue? I'm using TB 115.8 on Mac and I can't see the 'hamburger' menu or the 'film strip' icon that folks are suggesting to use.

I have c.160,000 emails since the late 1990s, all in several hundred work-related folders. Now when I search for an email, the results are shown in hierarchical threaded view, and I am supposed to hit multiple key strokes to get the default view unthreaded so there is a flat list of all emails that meet my search criteria. The option of manually going through all the folders to set default views that will be reset with the next software update isn't on the cards.

Surely there's a setting via the Config Editor to change the default settings from threaded to "I-never-ever-want-to-se-a-thread-ever-again"? [I looked for it but it wasn't there!]

any assistance welcomed thanks E

  1. 1
  2. 2