Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Autoscroll with middle mouse not working

  • 9 uphendule
  • 1 inale nkinga
  • 19 views
  • Igcine ukuphendulwa ngu cor-el

more options

I found a thread with the same problem while using X-Mouse Button Control; I am not using the software.

It only works sometimes while the page is still loading; doesn't work in safe mode.

I just installed the browser and was glad to use it, until I came upon this problem. I use this feature regularly while browsing the internet, so it would be a dealbreaker for me if I couldn't get it fixed.

Inside the GIF, you can see how the middle mouse doesn't toggle autoscroll, and it only works when holding the button.

I found a thread with the same problem while using X-Mouse Button Control; I am not using the software. It only works sometimes while the page is still loading; doesn't work in safe mode. I just installed the browser and was glad to use it, until I came upon this problem. I use this feature regularly while browsing the internet, so it would be a dealbreaker for me if I couldn't get it fixed. Inside the GIF, you can see how the middle mouse doesn't toggle autoscroll, and it only works when holding the button.
Ama-screenshot ananyekiwe

All Replies (9)

more options

The only way I managed to get it working was by holding down ALT or CTRL while pressing the middle mouse, an issue which doesn't arise on ony other browser.

more options

Hi

Are you using the most recent version of X-Mouse Button Control?

more options

You could check the value of the following hidden preference by entering about:config in the address bar. mousewheel.default.action The default is 1 which translates to scrolling contents.

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

more options

What kind of mouse do you use ? Does it come with its own Windows Mouse driver ?

Boot the computer in Windows Safe Mode with network support to see if that has effect.

more options

Paul said

Hi Are you using the most recent version of X-Mouse Button Control?

I am not using the software.

more options

cor-el said

What kind of mouse do you use ? Does it come with its own Windows Mouse driver ? Boot the computer in Windows Safe Mode with network support to see if that has effect.

I use a Logitech G502, which I assume does use its own drivers.

Autoscroll does work in Windows Safe Mode.

Okulungisiwe ngu simo.liguori

more options

Terry said

You could check the value of the following hidden preference by entering about:config in the address bar. mousewheel.default.action The default is 1 which translates to scrolling contents. https://support.mozilla.org/en-US/kb/about-config-editor-firefox

I checked it, and it is set to 1.

more options

Go to about:third-party in the address bar and try disabling any third-party modules then restart the browser.

more options

Make sure that the middle-mouse actions are set to default in the mouse driver settings as Logitech usually sets its own scroll actions what interferes with Firefox.