Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Twitter videos getting darker and with wrong colours when I fullscreen them. Same happen for all the videos on youtube (fullscreen and normal size)

  • 2 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu Guloma

more options

Since the last Firefox update (I'm now using Firefox 113.0.1 64bit on Windows 11) when I play a video on Twitter, it plays with the right colors until I fullscreen it. When I fullscreen it, the video becomes darker and the colors are wrong.

  • The same happens to youtube videos (both fullscreen or normal size): the colors are not right and they looks darker.
  • The same problem happens using both my laptop's internal monitor and the external monitor.
  • I tried to reinstall Firefox but it didn't fix it.
  • I also tried to take a screenshot of the "wrong colors" videos using the Windows screenshot tool but the output image is displayed with the right colors and not with the darker ones.
  • Using Chrome the colors are correct and I never had this problem before the last Firefox update.
Since the last Firefox update (I'm now using Firefox 113.0.1 64bit on Windows 11) when I play a video on Twitter, it plays with the right colors until I fullscreen it. When I fullscreen it, the video becomes darker and the colors are wrong. * The same happens to youtube videos (both fullscreen or normal size): the colors are not right and they looks darker. * The same problem happens using both my laptop's internal monitor and the external monitor. * I tried to reinstall Firefox but it didn't fix it. * I also tried to take a screenshot of the "wrong colors" videos using the Windows screenshot tool but the output image is displayed with the right colors and not with the darker ones. * Using Chrome the colors are correct and I never had this problem before the last Firefox update.

Isisombululo esikhethiwe

Must be something with color management. Try to go to about:config and set gfx.color_management.native_srgb to true. Does it work now?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (2)

more options

Isisombululo Esikhethiwe

Must be something with color management. Try to go to about:config and set gfx.color_management.native_srgb to true. Does it work now?

more options

Thanks, it worked just fine. I have no idea why the setting changed after the firefox update but setting it to true fixed the problem.