Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Sub-Folders don't show up in my bookmarks

  • 5 uphendule
  • 2 zinale nkinga
  • 66 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hi All,

A few of my sub-folders within my bookmarks do not show up in the Toolbar and Sidebar. The same bookmarks' sub-folder are present in the Bookmarks library (that's accessed from Firefox settings).

Could you please help with how I can get these sub-folders to show up in the Toolbar/Sidebar, please.

Thank you.

Hi All, A few of my sub-folders within my bookmarks do not show up in the Toolbar and Sidebar. The same bookmarks' sub-folder are present in the Bookmarks library (that's accessed from Firefox settings). Could you please help with how I can get these sub-folders to show up in the Toolbar/Sidebar, please. Thank you.

All Replies (5)

more options

To make a subfolder, click on "Add Folder..." and choose the folder you want to add your new folder under. To add a bookmark to a subfolder, find it in the "Add Bookmark" window or click and drag it to the right folder. Hover over the first folder until it opens up, then drop your bookmark in the right sub-folder.

This May Work, Peter

Helpful?

more options

AFAIK, they never have showed in the toolbar drop-downs. I see a folder icon then folder name followed by >. When I hover on that line, the files in the subfolder are displayed in a drop-down.

Okulungisiwe ngu Terry

Helpful?

more options

Terry said

AFAIK, they never have showed in the toolbar drop-downs. I see a folder icon then folder name followed by >. When I hover on that line, the files in the subfolder are displayed in a drop-down.

Hey Terry, thanks for the response. Yes, I have the subfolders defined, but the subfolder does not show up when inside of the main folder. Sorry, I don't know if that makes sense.

Helpful?

more options

Terry said

AFAIK, they never have showed in the toolbar drop-downs. I see a folder icon then folder name followed by >. When I hover on that line, the files in the subfolder are displayed in a drop-down.

Thank you, Peter. I have the subfolder created, however, the subfolder does not show up inside the main folder. But when I want to bookmark a page, I can click on the "star" icon and have the option to select my subfolder.

Okulungisiwe ngu estfor.sk

Helpful?

more options

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

this could be a problem with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder with Firefox closed. Firefox will rebuild places.sqlite and restore the bookmarks from the most recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created
  • you lose the history when a new places.sqlite is created

You may have to restore an older bookmarks backup in the bookmarkbackups folder via the Bookmarks Manager (Library).

See also:

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.