Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

v91 Changing the message composition body background color

more options

Recently my TB updated to v91. This created an issue for me as I'm low vision and have contrast issues. Basically most things went to a grey background.

The reading panel stayed with a black background, but the folders and threads panels went to grey. I was able to create a userChrome.css and use a snippet of code I found to get the folders and threads background back to black.

The message composition and reply windows are also grey background and I'd really like to get them back to black. I've tried the various font and color options, the font and background settings in the messages, etc., but they don't make any difference. I imagine that's because I created the userChrome.css file and toolkit.legacyUserProfileCustomizations.stylesheets in Preferences/General/Config is set to true, so it's probably ignoring the normal methods and using what's in the userChrome.css file.

Can anyone tell me how to get the message body composition backgrounds back to black (for both new and replies)?

I'd also like the message header info to have a black background too, but that's not a big deal -> the message composition bodies is though, grey just isn't good for my vision, pitch black with white text is best for me.

Thanks!

Steve

Recently my TB updated to v91. This created an issue for me as I'm low vision and have contrast issues. Basically most things went to a grey background. The reading panel stayed with a black background, but the folders and threads panels went to grey. I was able to create a userChrome.css and use a snippet of code I found to get the folders and threads background back to black. The message composition and reply windows are also grey background and I'd really like to get them back to black. I've tried the various font and color options, the font and background settings in the messages, etc., but they don't make any difference. I imagine that's because I created the userChrome.css file and toolkit.legacyUserProfileCustomizations.stylesheets in Preferences/General/Config is set to true, so it's probably ignoring the normal methods and using what's in the userChrome.css file. Can anyone tell me how to get the message body composition backgrounds back to black (for both new and replies)? I'd also like the message header info to have a black background too, but that's not a big deal -> the message composition bodies is though, grey just isn't good for my vision, pitch black with white text is best for me. Thanks! Steve

All Replies (5)

more options

I use the Dark theme and the 'Dark Reader' addon and it works perfectly.

Helpful?

more options

Thanks for the reply David, but theme changes don't fix my issues.

I know I fought this battle years ago and got it working perfectly for me. I don't recall what all I had to do though, again - it was years ago.

It was the recent update to v91 that changed things. It's not terrible, but black works sooo much better than grey for me.

Theme changes didn't fix it for me, and the normal configuration tweaks aren't either. Again, i imagine that's because I'm using the userChrome.css to fix the folder and thread pane backgrounds.

I'm sure this is a simple fix, just need the variable names to fix it in the userChrome.css like I did the folder and thread panes. I've located and extracted the omni.ja file and am trying to get it figured out. I've got a cold and a terrible sinus headache today though, so it's slow going.

I almost wonder if doing a fresh install would help as this install is migrated spanning many different TB versions, but I'm not up to that today, again, it halfway works for me, grey isn't unusable, it's just that black is sooo much better. I'm sure it's easily fixed, just need to find what to put into the .css file.

Helpful?

more options

Have you tried Tools>settings>general and clicking the Colors button and setting background to #000000?

Helpful?

more options

The attached is the best I could do.

Helpful?

more options

Yes, I have, doesn't work - again, I'm sure that's because I created the userChrome.css file and toolkit.legacyUserProfileCustomizations.stylesheets in Preferences/General/Config is set to true, so it's probably ignoring the normal methods and using what's in the userChrome.css file.

If I turn toolkit.legacyUserProfileCustomizations.stylesheets to false, then some of the normal tweaks work, but then the folder and threads panes I can't adjust.

Interestingly enough, if I turn toolkit.legacyUserProfileCustomizations.stylesheets to false and then go to Dark Reader, More, Change the Browser and hit default, nothing happens (it must think it's all defaulted already), but if I hit Custom it changes to an awful for my eyes layout, but then if I hit default again it's back to what it used to be....glorious pitch black and white!!! EVERYTHING changes, the the folder and threads, the reading pane, the composition pane, etc. all change to the pitch black and white that works so well for me!!!

Like I said, I have pounding sinuses today, so for now just load up TB flip it to the awful setting and flip it back to default, then minimize it when I'm not using it and life is good.

I'm sure this can all be easily fixed in the .css file, I just need the variable labels to set. Hopefully someone knows them, or I'll give more effort to digging into the omni.ja file when I'm feeling better.

Thanks for the efforts!!!

Steve

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.