Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Discord Can't Speak Messages

more options

Hi all. I am having a strange issue with Discord. I can get notification sounds and all other media plays fine there. But whenever I try to "speak comment" or set the settings to always speak comments, nothing happens. The tab shows "playing", but no audio comes out, and nothing shows coming through on the mixer.

Chrome does speak as expected. A different computer, same version of Firefox also does speak as expected (in a different voice though). So that narrows it down to something in this particular copy of Firefox that is causing the problem. Plugins, settings and extensions on the two computers look the same. Also tried a different audio interface. If anyone has any ideas, please let me know!

Specs: Windows 10, Firefox 91.0 32 bit (both computers)

Hi all. I am having a strange issue with Discord. I can get notification sounds and all other media plays fine there. But whenever I try to "speak comment" or set the settings to always speak comments, nothing happens. The tab shows "playing", but no audio comes out, and nothing shows coming through on the mixer. Chrome does speak as expected. A different computer, same version of Firefox also does speak as expected (in a different voice though). So that narrows it down to something in this particular copy of Firefox that is causing the problem. Plugins, settings and extensions on the two computers look the same. Also tried a different audio interface. If anyone has any ideas, please let me know! Specs: Windows 10, Firefox 91.0 32 bit (both computers)

All Replies (2)

more options

Did you check the settings in Discord for speaker and mic options? Make sure no Addons are on when troubleshooting if any are a installed.

Helpful?

more options

Input is my sound interface's mic jack. Output is "default", which according to Windows is my sound interface. I actually moved the whole appdata firefox roaming and local directories to the desktop so I could see if it was anything in my settings. Same thing, unfortunately. Maybe there's something about the way Firefox is talking to Windows audio? I will try changing to a different sound interface and see if that makes a difference.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.