Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Option to use Gmail for mailto: links has suddenly vanished from Settings

  • 5 uphendule
  • 2 zinale nkinga
  • 220 views
  • Igcine ukuphendulwa ngu bjkeefe

more options

Just now, I tried to use "Email Link..." under the File Menu and got a pop-up asking me to "Choose an application to open the mailto link." I have seen this before, several times, usually after updating Firefox, IIRC.

This time, however, Gmail is not presented as an option, in this pop-up. Clicking "Choose..." just opens up a Windows Explorer file-picker window.

I tried to fix this in Tools > Settings, under General > Applications. There, "mailto" just shows "Use other..." and if I click that, the "Select Helper Application" pop-up window is basically blank, with a message at the bottom saying "No applications were found for this file type."

See attached images.

I am running v98.0.2 on Win 10 Pro.

Just now, I tried to use "Email Link..." under the File Menu and got a pop-up asking me to "Choose an application to open the mailto link." I have seen this before, several times, usually after updating Firefox, IIRC. This time, however, Gmail is not presented as an option, in this pop-up. Clicking "Choose..." just opens up a Windows Explorer file-picker window. I tried to fix this in Tools > Settings, under General > Applications. There, "mailto" just shows "Use other..." and if I click that, the "Select Helper Application" pop-up window is basically blank, with a message at the bottom saying "No applications were found for this file type." See attached images. I am running v98.0.2 on Win 10 Pro.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

jscher2000 - Support Volunteer said

This could be a problem with the file that stores the list of download actions, named handlers.json. [...]

Thanks for your detailed advice, JS. It did not work, unfortunately. The new handlers.json file that got created is nearly empty, and in particular, did not have anything in it to do with mailto: links, and so, I saw the same problems as I originally described.

I tried adding in the what looked likely, copying from an older version of the handlers file (one of the .corrupt versions in the same folder):

"schemes":{"mailto":{"handlers":[{"name":"Gmail","uriTemplate":"https://mail.google.com/mail/?extsrc=mailto\u0026url=%s"}]}}}

Didn't work, though. And restarting Firefox just generated another new handlers.json file, again, with pretty much nothing in it.

So, I decided to click the big ol' Refresh button on the about:support page. Took a while, but when Firefox finally relaunched, the option to use Gmail to handle mailto: links was back. A bit of a nuisance to have to reset all of my other preferences, but it's worth it, to get the mailto: issue fixed. I do feel bad about such a ham-handed solution, but whaddya gonna do.

Thanks again, Brendan

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

Not sure why the first image won't display. I've tried uploading it again, with same null result. Hope the rest of my post is clear enough without it.

Helpful?

more options

The article below has some advice about adding an email address. I am also posting a link to a more technical method.

https://support.mozilla.org/en-US/kb/change-program-used-open-email-links#w_using-webmail-services https://support.mozilla.org/en-US/questions/1281202

Helpful?

more options

This could be a problem with the file that stores the list of download actions, named handlers.json.

If you don't find another solution, you could remove the current file and let Firefox generate a new one. Unfortunately, this means that actions you have assigned will need to be added again.

If necessary, this is how you would do it:

Open your current Firefox settings (AKA Firefox profile) folder using any one of these methods:

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, find the Profile Folder row. Click the "Open Folder" button on that row to launch a new window listing various files and folders in Windows File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

Right-click handlers.json then Rename to something like handlersOLD.json (so it's there for possible recovery later...).

Start Firefox back up again. Is Gmail back as an action for mailto links?

Helpful?

more options

Isisombululo Esikhethiwe

jscher2000 - Support Volunteer said

This could be a problem with the file that stores the list of download actions, named handlers.json. [...]

Thanks for your detailed advice, JS. It did not work, unfortunately. The new handlers.json file that got created is nearly empty, and in particular, did not have anything in it to do with mailto: links, and so, I saw the same problems as I originally described.

I tried adding in the what looked likely, copying from an older version of the handlers file (one of the .corrupt versions in the same folder):

"schemes":{"mailto":{"handlers":[{"name":"Gmail","uriTemplate":"https://mail.google.com/mail/?extsrc=mailto\u0026url=%s"}]}}}

Didn't work, though. And restarting Firefox just generated another new handlers.json file, again, with pretty much nothing in it.

So, I decided to click the big ol' Refresh button on the about:support page. Took a while, but when Firefox finally relaunched, the option to use Gmail to handle mailto: links was back. A bit of a nuisance to have to reset all of my other preferences, but it's worth it, to get the mailto: issue fixed. I do feel bad about such a ham-handed solution, but whaddya gonna do.

Thanks again, Brendan

Helpful?

more options

terry21 said

The article below has some advice about adding an email address. I am also posting a link to a more technical method. [...]

Thanks for your suggestions, Terry. I looked at them both, but as you'll note from my reply to jscher, I ended up resolving the issue before trying any of the ideas at those links.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.