Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Bookmarks toolbar doesn't show bookmarks

  • 5 uphendule
  • 2 zinale nkinga
  • 643 views
  • Igcine ukuphendulwa ngu cor-el

more options

In my library, I can see my bookmark in the "Bookmarks Toolbar" folder. However, the bookmark doesn't actually show on the toolbar.

In my library, I can see my bookmark in the "Bookmarks Toolbar" folder. However, the bookmark doesn't actually show on the toolbar.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

  • check that "Bookmarks Toolbar Items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar Items" is not on the Bookmarks Toolbar then drag it back from the Customize palette to the Customize window to the Bookmarks Toolbar
  • if missing items are in the Customize palette then drag them back from the Customize window to the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button in the Customize palette window to restore the default toolbar set.
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Let's make sure the Bookmarks Toolbar is turned on:

Customize Firefox controls, buttons and toolbars {web link}

Type about:customizing<enter> in the address box.

Note: about:customizing is no longer present in Firefox v47+ releases.

  • Press Alt or F10 to bring up the Menu Bar. Then View > Toolbars > Bookmarks Toolbar.
  • Right-click on a blank spot on the toolbar and select Bookmarks Toolbar.
  • Right-click on a blank spot on the toolbar and select Customize Toolbar.
    Look for Show / Hide Toolbars or just Toolbars at the bottom left.
    There is also a Restore Defaults button at the bottom right.
more options

I have checked if my bookmarks toolbar is on, and it is. The selected option is Always show. But I still can't see my bookmark.

more options

Hmm, very odd.

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address box and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You may have to approve the updating once again.

more options

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

This could be a problem with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder with Firefox closed. Firefox will rebuild places.sqlite and restore the bookmarks from the most recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created
  • you lose the history when a new places.sqlite is created

You may have to restore an older bookmarks backup in the bookmarkbackups folder via the Bookmarks Manager (Library).

See also:

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

more options

Isisombululo Esikhethiwe

  • check that "Bookmarks Toolbar Items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar Items" is not on the Bookmarks Toolbar then drag it back from the Customize palette to the Customize window to the Bookmarks Toolbar
  • if missing items are in the Customize palette then drag them back from the Customize window to the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button in the Customize palette window to restore the default toolbar set.