Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to make "Say hello to a new Firefox" not appear next time I open Firefox

  • 6 uphendule
  • 1 inale nkinga
  • 25 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hello,

I'm using Firefox 91.4.1esr (64-bit) from Debian repositories on Bullseye. Every time I open Firefox, a window with a greeting message appears ("Say hello to a new Firefox"), and it doesn't matter if, as asked by that window, I choose a theme or not. Is this issue related to my settings? Is this a Debian issue? Is it possible to stop that window from reappearing?

Thanks in advance. And many thanks for making Firefox (I've been using it for so many years I can't recall when I tried it for the first time).

Esteban

Hello, I'm using Firefox 91.4.1esr (64-bit) from Debian repositories on Bullseye. Every time I open Firefox, a window with a greeting message appears ("Say hello to a new Firefox"), and it doesn't matter if, as asked by that window, I choose a theme or not. Is this issue related to my settings? Is this a Debian issue? Is it possible to stop that window from reappearing? Thanks in advance. And many thanks for making Firefox (I've been using it for so many years I can't recall when I tried it for the first time). Esteban

Isisombululo esikhethiwe

I'm very sorry, it was my mistake. I run Firefox from RAM and then save my profile to disk, but the script I use wasn't working because it found a lock file left in the profile's temporary folder. Thank you very much for trying to help, and apologies again.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

Hi Esteban, I think that should only appear after an update. If it appears at every startup, possibly it has been added as a second "home page" or is a pinned tab.

On the Preferences page, Home panel, when Custom URLs is selected, there is a field listing home page(s). It can store multiple URLs separated by vertical bar ("|") characters. So that's the first thing to check. See: How to set the home page.

Pinned tabs have only the site icon, not the title, so that's easy to rule out. More info: Pinned Tabs - keep favorite websites open and just a click away.

Another possible explanation might be something in a user.js file. Firefox will read that optional file at startup, if it exists, and use its contents to override your regular settings. This article describes how to check for that file: How to fix preferences that won't save.

Any progress so far?

Helpful?

more options

You can possibly try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Helpful?

more options

Isisombululo Esikhethiwe

I'm very sorry, it was my mistake. I run Firefox from RAM and then save my profile to disk, but the script I use wasn't working because it found a lock file left in the profile's temporary folder. Thank you very much for trying to help, and apologies again.

Helpful?

more options

Thank you for reporting back. It's always good to understand the situation.

Helpful?

more options

Is there any way to permanently disable this message? Firefox updates often and it's already a hassle to restart it after every update. The message is 100% useless and serves only the amusement of the Firefox developers and graphic artists. As a user, it is nothing but spam. How can I disable this message?

Helpful?

more options

You can try to set this pref to false on the about:config page.

  • browser.aboutwelcome.enabled = false

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.