Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to disable alt+shift+s opeing menu bar history panel

  • 3 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu Inkiad

more options

I'm using a web app that uses this shortcut (alt+shift+s), but every time I press this to trigger that action annoying menu bar pops up with the history panel opened. I've already disabled menu opening while pressing alt by making [ui.key.menuAccessKeyFocuses to false] . Now how do I disable this? Also, It would be great if I could remove this menu bar altogether permanently.

I'm using a web app that uses this shortcut (alt+shift+s), but every time I press this to trigger that action annoying menu bar pops up with the history panel opened. I've already disabled menu opening while pressing alt by making [ui.key.menuAccessKeyFocuses to false] . Now how do I disable this? Also, It would be great if I could remove this menu bar altogether permanently.
Ama-screenshot ananyekiwe

Okulungisiwe ngu Inkiad

Isisombululo esikhethiwe

Web pages that intercept keyboard shortcuts which also trigger a built-in action need to cancel certain events to prevent Firefox from also receiving them. It's possible the site has not added that extra code because other browsers no longer have an address bar.

To disable the menu access key, you can try this (not officially supported, but worked for me):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste ui.key.menuAccessKey and pause while the list is filtered

(3) Double-click the ui.key.menuAccessKey preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change.

For reference, the accesskey/accelkey preferences recognize the following values:

  • 0 => disable
  • 17 => Ctrl key
  • 18 => Alt key
  • 91 => Windows key
  • 224 => Meta (Command key on Mac??)

(4) Do a regular exit/restart of Firefox and then test. Firefox should now ignore Alt+F, Alt+S, Alt+B, etc.

More info on about:config: Configuration Editor for Firefox.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Is there an accesskey="s" set on a webpage or is this access key used by an extension ?

In case of the latter, this might not work and you can try to set a different access key for this extension via the about:addons page.

Okulungisiwe ngu cor-el

more options

Isisombululo Esikhethiwe

Web pages that intercept keyboard shortcuts which also trigger a built-in action need to cancel certain events to prevent Firefox from also receiving them. It's possible the site has not added that extra code because other browsers no longer have an address bar.

To disable the menu access key, you can try this (not officially supported, but worked for me):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste ui.key.menuAccessKey and pause while the list is filtered

(3) Double-click the ui.key.menuAccessKey preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change.

For reference, the accesskey/accelkey preferences recognize the following values:

  • 0 => disable
  • 17 => Ctrl key
  • 18 => Alt key
  • 91 => Windows key
  • 224 => Meta (Command key on Mac??)

(4) Do a regular exit/restart of Firefox and then test. Firefox should now ignore Alt+F, Alt+S, Alt+B, etc.

More info on about:config: Configuration Editor for Firefox.

more options

jscher2000 said

Web pages that intercept keyboard shortcuts which also trigger a built-in action need to cancel certain events to prevent Firefox from also receiving them. It's possible the site has not added that extra code because other browsers no longer have an address bar. To disable the menu access key, you can try this (not officially supported, but worked for me): (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste ui.key.menuAccessKey and pause while the list is filtered (3) Double-click the ui.key.menuAccessKey preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change. For reference, the accesskey/accelkey preferences recognize the following values:
  • 0 => disable
  • 17 => Ctrl key
  • 18 => Alt key
  • 91 => Windows key
  • 224 => Meta (Command key on Mac??)
(4) Do a regular exit/restart of Firefox and then test. Firefox should now ignore Alt+F, Alt+S, Alt+B, etc. More info on about:config: Configuration Editor for Firefox.

Thank you, this worked for me too.