Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Http redirecting to Https

  • 1 baphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu cor-el

more options

I am having trouble accessing a site that doesn't support https. For the longest time, I could access it just fine through http, but now, for some reason, it redirects to https, no matter what I do, which just gives me a cloudflare error.

I can access it in other browsers by just editing the address to http://xyz.com rather than https://xyz.com.

I'm aware others have encountered this issue, but the proposed solutions do not work for me at all.

I've tried: -Clearing my site security preferences file. -"Forgetting" the site through my history. -Disabling my addons -Disabling 'network.stricttransportsecurity.preloadlist' and 'browser.fixup.fallback-to-https' in my about:config. -Ensuring that https only mode is not on.

A Refresh DID fix it... only for it to break again pretty much immediately after I reloaded the site.

This is exceptionally annoying, as I have my Firefox configured how I want it, and I don't want to swap to another browser. Any solutions?

I am having trouble accessing a site that doesn't support https. For the longest time, I could access it just fine through http, but now, for some reason, it redirects to https, no matter what I do, which just gives me a cloudflare error. I can access it in other browsers by just editing the address to http://xyz.com rather than https://xyz.com. I'm aware others have encountered this issue, but the proposed solutions do not work for me at all. I've tried: -Clearing my site security preferences file. -"Forgetting" the site through my history. -Disabling my addons -Disabling 'network.stricttransportsecurity.preloadlist' and 'browser.fixup.fallback-to-https' in my about:config. -Ensuring that https only mode is not on. A Refresh DID fix it... only for it to break again pretty much immediately after I reloaded the site. This is exceptionally annoying, as I have my Firefox configured how I want it, and I don't want to swap to another browser. Any solutions?

All Replies (1)

more options

Did you try to create an 'Off' exception for HTTPS-Only via the padlock with HTTPS-Only enabled ?

Note that creating an HTTPS Only mode exception might not work if you have set network.trr.mode to 2 or 3 (0 or 1 should work) on the about:config page and Firefox insists in forcing HTTPS.