Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dark Theme

more options

Dark Mode used to work beautifully in Firefox. Today it stopped working. I can choose Dark Mode in the settings page, and the settings page itself then uses Dark Mode. But Dark Mode does not work in any of the other pages, only the settings page. I think it must be a flaw in an update that was installed automatically today. (September 7, 2021)

Is there a way to uninstall this update and go back to the previous version. Dark Mode used to work beautifully and Firefox was my favorite browser. Can someone help? Thanks.

All Replies (3)

more options

Hi, could you describe what you've set so far? For example,

(1) Theme - using the Dark theme. See: Built-in themes in Firefox - alternative to complete themes

(2) Another setting?


Firefox would normally detect your system theme as a cue for whether to apply a dark theme. There is an override for that which you could experiment with. (Apologies for the old screenshots.)

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box, type or paste ui.systemUsesDarkTheme

(C) Firefox should display a bar with some radio buttons to choose a new preference type, followed by a + button. Choose Number and click the + button:

(D) Edit the value to either 0 (Light) or 1 (Dark) and then click the blue check mark button or press Enter/Return to save the change.

You should noticed a change immediately on the about:config page.

[Warning added by moderator.]

Okulungisiwe ngu Chris Ilias

Helpful?

more options

Hi.

I went to Settings / Manage more settings / Extensions and themes. I enabled the built-in Dark theme. But the opening page and all all pages open up with a light theme, except for the Settings page only.

Thanks.

Helpful?

more options

It is the background that is not going to black. I went into "Settings", "General", down to "Language and Appearance", "Colors". I changed the "Text" color to White and the "Background" color to Black. All is good now but I also have my system in High Contrast mode as always. For whatever reason Firefox is ignoring that I am in High Contrast mode. If you don't run the system in High Contrast mode, you can change the "Override the colors specified by the page with your selections above" with "Always" instead of the "Only with High Contrast themes".

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.