Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

TB keeps asking me to download the latest version, even though I already have it

  • 20 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu MrYossu

more options

Been using TB for donkey's years, no problems. Just recently, I get a pop-up message in the TB window saying it can't download the latest version, and giving me a link to download it manually.

Putting aside the question of why it can't download automatically (any ideas anyone?), why does it even do this when I'm on the latest version? I can see the version in Help -> About, and this is the same version as the latest downloader.

Anyone any ideas? I get this pop-up several times a day, and it's annoying. Thanks

Been using TB for donkey's years, no problems. Just recently, I get a pop-up message in the TB window saying it can't download the latest version, and giving me a link to download it manually. Putting aside the question of why it can't download automatically (any ideas anyone?), why does it even do this when I'm on the latest version? I can see the version in Help -> About, and this is the same version as the latest downloader. Anyone any ideas? I get this pop-up several times a day, and it's annoying. Thanks

All Replies (20)

more options

Does help> about report your current version as 32 bit and your operating system is 64 bit perhaps.

more options

Hello, thanks for the reply.

No, it reports 64-bit correctly. Please see the attached image.

Any other ideas? Thanks again.

more options

Can you please capture one of the notices requesting you update?

more options

Sure, here you go.

Thanks again.

more options

It is also telling you that is is unable to download the update. You scribbled over the version information in your initial post, but there have been multiple releases in the V91 tree already due to bugs that have been found. The current release is 91.0.3 and your red covers that crucial information. Do you have the current version?

Please go to the troubleshooting information on the help menu and click on the show update history button. What updates does it show occurring?

(I am trying to understand your setup. I know little is being achieved, but this is a toughie)

more options

Hello again.

Sorry, I was highlighting the fact that I was on the 64-bit version, and accidentally scribbled over the version number.

Anyway, I just got the pop-up again, and as you can see, I am indeed already on version 91.0.3 (no scribbles this time!).

As requested, I've also attached a snapshot of the update history. As you can see, the automatic updates haven't happened since Dec '20. I've done them manually since then.

Thanks again for the help, I appreciate it.

more options

I have two installation of Thunderbird running on identicaI but separate profiles.

One version was using 68.12.0 and I auto updated at prompt to version 78.14.0 When I look in update history, it shows both versions listed. It auto updated to 78.14.0 because there is no current auto update to version 91*. However, if using an updater software program they would not know about updating 78.13.0 to 78.14.0. They would only know about a new release eg: 91.0.3

The other version was running 78.14.0. In this case, I removed/uninstalled the 78.14.0 version and then downloaded and installed the 91.0.3 version. When I look in update history, it says no updates have been performed as yet - which is true as it is a completely new installation done by me.

Did you completely remove the 78* version and then download and install the 91* version OR did you install over the top of the other?

more options

@Toad-Hall If I remember correctly, whenever there is an update, TB gives me this message, so I have to download manually. This downloads the full installer, which seems to update rather than installing a separate version.

How would I tell if I have multiple versions installed? The Programs app in COntrol Panel just shows the one version (91.0.3), but my AppData\Local\Thunderbird\Profiles folder has three folders in it...

0xsvrpc3.default 205zn24y.default-release x4xlks17.default

AppData\Roaming\Thunderbird\Profiles has three identically-named folders.

Does that help? Thanks

Okulungisiwe ngu MrYossu

more options

re : but my AppData\Local\Thunderbird\Profiles folder has three folders in it... These are put there by Windows OS and they are used as a cache. You do not need to be concerned with them as they do not have your profile information nor emails or indeed anything of use to you.

re :AppData\Roaming\Thunderbird\Profiles has three identically-named folders. This is the location of your profile. These three folders are 'profile name' folders and one of them is your current profile.

  • 0xsvrpc3.default
  • 205zn24y.default-release
  • x4xlks17.default

When you perform a backup, you would exit Thunderbird first and then copy that 'Thunderbird' folder (as highlighted above) and paste the copy into a suitable location eg: external drive.

Those 'profile name' folders are not causing this issue.

However, getting back to what I mentioned - I uninstalled the Program and then downloaded and installed latest version. This meant my updates information was blank. I have since been offered an update, which was a proper update and now I have that update informaion showing in the update history.

I also only allow Thunderbird to check for updates. I do not use or allow any updater software to check for updates as they may try to install an incorrect update. For example those running 78.13.0 would not be offered version 91* as an update by Thunderbird; they would be offered 78.14.0, but updater software on computer would not be aware of this.

Please uninstall the current version via the following method to see if this fixes the problem. Exit Thunderbird now if it is running Access: C:\Program Files (x86)\ Delete the 'Mozilla Thunderbird' folder

Also check C:\Program Files and if you see 'Mozilla Thunderbird' folder - delete it.

Then Empty the computer 'Recycle Bin'

Download the same version as you were using which according to the images was version 91.0.3 Get it from this link: Choose your prefered language eg: en-GB is English British Then click on the 'Thunderbird Setup 91.0.3.exe' link to download and install as new. Once it is running, first check settings Preferences > General Scroll to the Updates section and click on - 'Show updates history' Is it now blank?

Suggest you select the following:

  • Select 'check for updates but let me choose whether to install them'
  • Uncheck the checkbox 'Use a background service to install updates' - if it is selected.

Thunderbird has released further updates, so expect Thunderbird to prompt for an update and then select to install the update.

Does it update ok? You may need to restart - note I selected to update and oddly, it did not offer the prompt to restart, but in Help > About Thunderbird - there was the 'restart to update' button which I used. Then go and check the Preferences update info again to see what has been put into the update history information.

more options

@Toad-Hall Thanks for your detailed response. Sorry, been off for a week, so only just had chance to try this.

I followed your instructions exactly. The only thing that struck me as odd was that when I came to delete the old installation, I didn't have anything in C:\Program Files, only in C:\Program Files (x86), but when I reinstalled as you suggested, it used C:\Program Files. Not sure if this has any relevance.

Anyway, TB works as before, but has not offered me any updates. Looking in the About window, it shows that I'm on 91.0.3 (which is the version I downloaded as you suggested), but claims this is the latest version, see screenshot. I can see from the project web site that this is not the latest version.

I didn't get a button to restart, but did so anyway. It looked exactly he same after restarting, still on version 91.0.3, and no restart button.

I set the preferences, see screenshot, and the update history window is empty as expected.

Any ideas? Thanks again.

more options

Hello again,

After posting yesterday, I tried uninstalling TB via the settings, then deleting the folders as above. I then downloaded the latest version (not 91.0.3) and installing that. I checked that the settings were all as you suggested.

TB has just popped up the same message (albeit slightly redesigned), telling me it can't update.

Any ideas? Thanks again.

more options

@Toad-Hall (or anyone), and ideas? This is really annoying

more options

Sorry for delay. I've been checking out similar issue in Bugzilla. It is possible your Anti-Virus/Firewall product is blocking access to ''

What Anti-Virus product are you using ? for example: If using Kaspersly free anti virus Add to Network Settings > Trusted domains

more options

@Toad-Hall Thanks for the reply.

I'm using ESET EndPoint anti-virus. I don't think it's blocking access, as if I click the link, I get a message saying the requested URL was not found on the server, which means it reached the server.

I set Fiddler going earlier, to see if I could catch when the pop-up comes, but predictably, I've not seen it today!

Thanks for the reply. Assuming the access isn't blocked, where do we go from here?

more options

Exit all programs. REStart computer in 'Safe Mode with Networking' mode start Thunderbird

It should ask to update at some point. Stay in 'Safe Mode with Networking' mode until you get the update prompt and report back on whether the update actually occurs.

more options

@Toad-Hall Thanks for the reply.

I'll give it a go, but given that when I tried to catch it accessing the other day, it went all day without showing the pop-up, I'm not sure how far I'll get with this, as I need to work as well, and safe mode isn't the best experience for that.

Thanks again, I'll see what happens.

more options

It will confirm whether ESET is interfering or not. Also then check this: In Thunderbird, Help > About Thunderbird Your last image said it was up to date. The latest is now version 91.2.0 Does it now check for update and offer you to download and install ? If yes, does it actually download and install latest version?

more options

Query: EDS address book sharing The following has been shown to cause the same sort of issue you mention, so please check to see if it effects you.

Help > More Troubleshooting Information Under 'Application Basics' - 'Profile Folder' - click on 'Open Folder' A new window opens showing the contents of your Profile name folder.

Exit Thunderbird now

Scroll down and look for 'prefs.js' file.

As a backup - copy the 'prefs.js' file and put it on desktop. You will only need this copy if you make an error with modifying the 'prefs.js' file.

In the 'profile' open the original 'prefs.js' file using a text editor like Notepad. Look for a user_pref that starts with: ldap_2.servers.eds If you see any lines that specifically start with that

  • user_pref("ldap_2.servers.eds.description", "EDS Address Book Bootstrapper");
  • user_pref("ldap_2.servers.eds.dirType", 3);
  • user_pref("ldap_2.servers.eds.filename", "eds.mab");
  • user_pref("ldap_2.servers.eds.position", 1);
  • user_pref("ldap_2.servers.eds.uri", "moz-abedsdirectory://");

Please delete those lines. Make sure to close up/remove any empty lines. Save the file.

Start Thunderbird.

more options

@Toad-Hall Thanks for the reply, but prefs.js didn't include any lines like that. The only two instances of "ldap" in the file were...

user_pref("ldap_2.servers.history.uid", "c4d901aa-7e68-477a-92c4-6b176a249758"); user_pref("ldap_2.servers.pab.uid", "a803a2ad-06b4-44b9-8d15-cb1819cd61a3");

...which I guess isn't relevant to your answer.

Thanks again, any other ideas?

more options

@Toad-Hall (or anyone), any ideas?