Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Double spacing in Menus is back :'-(

  • 34 uphendule
  • 6 zinale nkinga
  • 359 views
  • Igcine ukuphendulwa ngu stormcloud

more options

A few months ago Firefox decided to double space all the items in menus. Reading through the forums many people didn't like this because of the amount of space that the menus now take up. Fortunately there was a work around, by setting 'browser.proton.contextmenus.enabled to false they returned to normal

This morning Firefox my got upgraded and the double spacing problem is back again. However there appears to be a bug with the setting and the menus won't return to normal. I'm now stuck with stupidly large menus that won't fit on the screen and lots of painful scrolling.

Does anybody have an alternative workaround until this is fixed?

All Replies (20)

more options

I should probably say, this is FireFox version 91.0 running on Windows 10

Helpful?

more options

Hi

The configuration preference you mention was left in for testing and was due to be removed with this update.

There is no way that I am aware of to make the changes you are looking for, but this may be something that we consider in a future update.

Helpful?

more options

Well, thanks for getting back to me, but why remove something when people contacted this forum to say they needed it? Some people might think that FireFox might looks pretty with the change (but that's subjective), but if it makes it harder to use the browser then this is serious issue

Helpful?

more options

It is amazing how Firefox managed to develop such a defect. Huge spaces are not an accident. Forcing extra scrolling is not an accident. Forcing a design that makes it easier to get RSI is a poor design.

I'm trying to come up with a workaround.

There are several others asking for help on this. You will see this question being repeated quite a few times.

Helpful?

more options

Toad-Hall said

It is amazing how Firefox managed to develop such a defect. Huge spaces are not an accident. Forcing extra scrolling is not an accident. Forcing a design that makes it easier to get RSI is a poor design.

All of that is true, but the most bizarre bit about it is that Mozilla removed the workaround when people had already complained so they knew this was an going to be issue

Toad-Hall said

I'm trying to come up with a workaround.

Yes please. Yesterday Firefox was usable, but today it's not.

Helpful?

more options

Managed to get a fix. This is easier than you may think. Check a setting in Firefox about:config Access profile,create a folder, create a file and you do not need to write code because I have supplied the text, you just copy and paste. So work through instructions step by step. Note: I have added an image below to show process. If you cannot see details, access forum and click on image to enlarge.

  • Open 'about:config'

Info at link if unsure but basically type about:config in the address text bar. https://support.mozilla.org/en-US/kb/about-config-editor-firefox

  • in search type: legacy
  • look for: toolkit.legacyUserProfileCustomizations.stylesheets
  • make sure it is set to 'True'

Now access the profile itself:

  • Menu app icon > Help > More Troubleshooting Information
  • About 11th in list is 'Profile Folder' - click on the 'Open Folder' button

A new window opens showing the contents of your Firefox profile.

  • Create a new folder and call it chrome - it must be spelt correctly - all lowercase.
  • Open a text editor eg: Notepad
  • Copy all the text shown between the lines below and paste it into 'Notepad'.

I advise you double check the content shown in the email you receive is the same as the info posted in this forum question.


menupopup > menuitem, menupopup > menu {
  padding-block: 3px !important;
}
:root {
  --arrowpanel-menuitem-padding: 4px 8px !important;
}


  • Exit Firefox now - you need to close the browser; this is important.

The Notepad document:

  • File > Save As
  • Choose where to save it - it must be saved in the 'chrome' folder you just created.
  • Save the Notepad file with this name: userChrome.css

All lowercase except for the 'C' which is uppercase.

  • Make sure the 'Save as Type' is 'All files' - not a text document.
  • click on 'Save'

In the 'chrome' folder, it's type will be described as 'Cascading Style sheet.

Start Firefox

Helpful?

more options

I'm trying to see if I can get this 'space' auto reversed. I created a bug - perhaps you could offer support and post comment. https://bugzilla.mozilla.org/show_bug.cgi?id=1725401

Helpful?

more options

Toad-Hall said

I'm trying to see if I can get this 'space' auto reversed. I created a bug - perhaps you could offer support and post comment. https://bugzilla.mozilla.org/show_bug.cgi?id=1725401

Thanks for taking the time to look at this. As suggested I've added a some comments to the defect. I imagine you are going to see a lot of people complaining about the update, so let's hope they follow up on that defect something quickly.

Helpful?

more options

This double space bug has finally killed my loyalty to Mozilla.

Been here since Navigator, but I've had enough of these BS updates. 

Went browser shopping. Not liking chrome, but Opera seems nice and well built.

Might even try ... 

edge.

Okulungisiwe ngu 92532b

Helpful?

more options

92532b said

This double space bug has finally killed my loyalty to Mozilla. Been here since Navigator, but I've had enough of these BS updates. Went browser shopping. Not liking chrome, but Opera seems nice and well built. Might even try ... edge.

My comment regarding userChrome.css works perfectly and will continue to work. Your comment does not mention anything about the solution offered nor does it provide the person who asked the question with any useful information. Nor does it mention if you accessed the bug report and posted a comment explaining the computer you use and the problems you are experiencing. It would be helpful to have people make comments of support, otherwise I'm fighting this issue on my own. Please note, this forum is not a blog.

Helpful?

more options

We are looking forward to something in a future update which will tighten up menu spacing when you turn on the optional Compact mode. We don't yet know when that will arrive (maybe in Firefox 92?).

Until then... userChrome.css is your best workaround.

Helpful?

more options

I have the exact same problem on the Macintosh. Think about this. Many people enjoy Firefox for it's reliability. They have grown to know their expectations that when they run Firefox, they will have their expectations realized. This is important. The last couple of upgrades have changed Firefox enough to dampen their expectations to the extent that we might jump ship. This is written, not in the spirit of a blog, but as a direct affront to user reliability expectations. This is serious. Twice in a row we have seen enough change to warrant these comments so that those people who update Firefox start thinking that we might need to slow down these major changes. Again, think about this. Many user controllable changes were able to be controlled via add-ons or extensions. But now, users not geeks or savvy programmers are put into the position of having NO options to get the user interface they enjoyed. Now a CSS script is the only way to deal with the changes. This is simply wrong. I for one saw in Firefox version 92 the menu items double their spacing. And as in this Support page we see a CSS solution. But for me it did not work. I spent over 3 hours on this problem only having to give up and live with it. I should not have to do that. I beg the programmers to take seriously my considered opinion provided here. If this is not controlled, I suspect the loved Firefox browser may take a long term slide downward. Sincerely...

Okulungisiwe ngu three60guy

Helpful?

more options

Hi three60guy, Mozilla is aware of the desire for more compact menus -- it is one of the most popular ideas on Mozilla's new "ideas" site: https://mozilla.crowdicity.com/post/720482

There is work under way to tighten up the bookmark menus that drop from the main and bookmarks toolbar. In Firefox 93 (next release), the optional Compact density setting will do that. Here's a preview from the "Developer Edition" (based on the beta test version of Firefox 93):

However, Firefox 93 isn't scheduled to release until early October.

Until then, what support volunteers can suggest is limited. Note that in Firefox 92, the menus that drop from the Bookmarks Toolbar have a revised style, so you need to modify the Firefox 89-91 CSS:

/*** Tighten up drop-down/context/popup menu spacing (8 Sep 2021) ***/

menupopup:not(.in-menulist) > menuitem, 
menupopup:not(.in-menulist) > menu {
  padding-block: 2px !important; /* reduce to 1px or 0px as needed */ 
  min-height: unset !important; /* v92.0 - for padding below 4px */
}
:root {
  --arrowpanel-menuitem-padding: 4px 8px !important;
}

Helpful?

more options

jscher2000 said

Hi three60guy, Mozilla is aware of the desire for more compact menus -- it is one of the most popular ideas on Mozilla's new "ideas" site: https://mozilla.crowdicity.com/post/720482 There is work under way to tighten up the bookmark menus that drop from the main and bookmarks toolbar. In Firefox 93 (next release), the optional Compact density setting will do that. Here's a preview from the "Developer Edition" (based on the beta test version of Firefox 93): However, Firefox 93 isn't scheduled to release until early October.

Many thanks to jscher2000 for keeping folks updated. It's good to know that the developers are listening to Users and we can expect an option to fix the display in the not too distant future.

Helpful?

more options

1. Is Firefox 93 out yet?

2. Has the too-much-spacing-in-menus-bug been fixed? By which I mean, is there now a "compact mode" setting which puts things back the way they were before the developers got all space-happy? Because...

3. ... I don't want to install it until I know that!

Helpful?

more options

c.dudley said

1. Is Firefox 93 out yet? 2. Has the too-much-spacing-in-menus-bug been fixed? By which I mean, is there now a "compact mode" setting which puts things back the way they were before the developers got all space-happy? Because... 3. ... I don't want to install it until I know that!

It doesn't look like it  :'-(

I can't keep on using this broken browser, so I've started looking at alternatives.

Helpful?

more options

Yes, it's fixed in 93 in a compact mode, as promised.

Okulungisiwe ngu TyDraniu

Helpful?

more options

c.dudley said

Has the too-much-spacing-in-menus-bug been fixed? By which I mean, is there now a "compact mode" setting which puts things back the way they were before the developers got all space-happy?

Not all of the things, but the most requested things:

  1. Bookmarks Toolbar folder drop-downs: Starting in Fx93, Compact Mode density tightens these up
  2. Bookmarks Menu button () drop-down: Starting in Fx93, Compact Mode density tightens this up (see earlier screenshot)
  3. Top menu bar (File, Edit, View, History, Bookmarks, Tools, Help) drop-downs: Compact Mode density has no effect
  4. Right-click context menus: Compact Mode density has no effect

Helpful?

more options

jscher2000 said

c.dudley said

Has the too-much-spacing-in-menus-bug been fixed? By which I mean, is there now a "compact mode" setting which puts things back the way they were before the developers got all space-happy?

Not all of the things, but the most requested things:

I'm using version 93.0 (64 bit) on windows 10 but I'm not seeing any of these improvements. Is there something we have to do do enable it? I've tried:

  • Looking through the menus and settings for a "compact mode" - I can't see anything
  • under about:config I've toggled the browser.compactmode.show but this doesn't appear to do anything
  • Under "More Tools | Customise toolbar" There is a density setting called, quite literally, "Compact (not supported)", this does change few settings, but not the spacing of menu items

Helpful?

more options

jscher2000 said

  1. Top menu bar (File, Edit, View, History, Bookmarks, Tools, Help) drop-downs: Compact Mode density has no effect


Well, that is very unfortunate, because I use these menus a lot, especially the Bookmarks menu.

Do the css fixes that work for FF91 at least still work in FF93? And if i allow an upgrade from 91 to 93, will the fix still work, or do I have to re-apply it?

Helpful?

  1. 1
  2. 2
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.