Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google maps suddenly will not allow Firefox to display maps on website

  • 6 uphendule
  • 1 inale nkinga
  • 37 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Suddenly on my Wordpress website all the embedded google maps on posts are showing "maps.google.com will not allow Firefox to display the page if another site has embedded it". They've worked for months. Won't display on Firefox or Firefox Android. I can't even edit the maps in WP (Elementor widget) - shows the same banner.  ?

Isisombululo esikhethiwe

Thanks for your help, but stop the presses.... just heard back from Elementor support, it's an issue with their plugin. Here's the info in case others run into the same problem:

This is a known issue that started to occur recently. Our developers are currently aware of this issue and will find a solution as soon as possible. The problem seems to be with the Google Maps API, I am afraid I don't have an ETA when this issue will be addressed.

You can keep an eye on the changelog of Elementor https://elementor.com/help/changelog-of-elementor/

Also, here is a temporary workaround for this issue: Go to google.com/maps > find the address you need> click on menu> choose 'Share or embed map'> select the 'Embed a map' tab> adjust your preferred size (Small/Medium/Large/Custom size)> copy the link. Go to the Elementor editor>add an HTML widget> paste the copied link.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

What does your embed code look like? I'm not sure how much you control that versus a plugin, but you can check the source of your page as served to Firefox. Normally it's an iframe with a source address on https://www.google.com/maps/embed? followed by a ton of characters. For example,

<iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d1621.3884166441112!2d139.7150777033094!3d35.63322776104815!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x60188b1927d7963d%3A0xe69392b1bde0e4f7!2sTonkatsu%20Tonki!5e0!3m2!1sen!2sus!4v1622043284985!5m2!1sen!2sus" width="600" height="450" style="border:0;" allowfullscreen="" loading="lazy"></iframe>

Helpful?

more options

Thanks for your help. Is this what we're looking for?

<iframe scrolling="no" marginheight="0" marginwidth="0" src="https://maps.google.com/maps?q=Gerstle%20Cove%20Salt%20Point%20State%20Park&t=m&z=12&output=embed&iwloc=near" title="Gerstle Cove Salt Point State Park" aria-label="Gerstle Cove Salt Point State Park" frameborder="0"></iframe>

Helpful?

more options

overwater said

src="https://maps.google.com/maps?q=Gerstle%20Cove%20Salt%20Point%20State%20Park&t=m&z=12&output=embed&iwloc=near"

I think you need the other link. When you are viewing the map on Google maps and click the share button, on the Embed panel, you can find the embedding link.

Or if that isn't usable with your plugin, maybe check with the author/publisher on how theirs works.

Helpful?

more options

Solution below

Okulungisiwe ngu overwater

Helpful?

more options

Isisombululo Esikhethiwe

Thanks for your help, but stop the presses.... just heard back from Elementor support, it's an issue with their plugin. Here's the info in case others run into the same problem:

This is a known issue that started to occur recently. Our developers are currently aware of this issue and will find a solution as soon as possible. The problem seems to be with the Google Maps API, I am afraid I don't have an ETA when this issue will be addressed.

You can keep an eye on the changelog of Elementor https://elementor.com/help/changelog-of-elementor/

Also, here is a temporary workaround for this issue: Go to google.com/maps > find the address you need> click on menu> choose 'Share or embed map'> select the 'Embed a map' tab> adjust your preferred size (Small/Medium/Large/Custom size)> copy the link. Go to the Elementor editor>add an HTML widget> paste the copied link.

Helpful?

more options

Yes, the info from Elementor makes sense. But it's a bummer if you have used this plugin for a lot of posts. They need a global workaround!

Anyway, the old link just isn't working any more. You can verify by right-clicking the error message, expanding This Frame, and using Open Frame in New Tab.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.