Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Roboform

  • 8 uphendule
  • 1 inale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu 2stevem

more options

I have used Roboform password manager with FF for years. Within the last 6 months, Roboform's toolbar no longer automatically displays below FF when I open FF. I have to force it to by going into RF options and dragging the RF icon onto FF (see attached screen shot). As shown in the image, RF and/or FF doesn't even think RF is installed! But it is. I've contacted RF multiple times, and they claim they're working on it. I wonder if anyone in the FF community has the same problem. Thanks for any help. Steve

Ama-screenshot ananyekiwe

All Replies (8)

more options

Hi Steve, I'm not familiar with that installation technique. Generally speaking, if you drag an extension file (XPI file) from Windows File Explorer into the body of a tab, after several moments, Firefox will drop-down a panel from the left end of the toolbar about installing it. Maybe that is what is supposed to happen?

Alternatively, what about trying to install from the Mozilla Add-ons site. I don't know if this is the identical version or not:

https://addons.mozilla.org/firefox/addon/roboform/

Any progress? Also, please double-check whether the extension appears on the Add-ons page as an installed extension in case the problem is not failure to install but failure to run. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading and review the list that follows.

Helpful?

more options

Did you ever use the refresh feature in Firefox or otherwise created a new profile ?

Helpful?

more options

Hi, thank you for your time and responses. They did not resolve the problem with Roboform. Steve

Helpful?

more options

Steve, please give more detail about what is happening in your Firefox?

  • Do you get an error when installing from the Add-ons site link?
  • Is Roboform listed on the Add-ons page or not?

Helpful?

more options

Hi, thanks for responding. In answer to your questions: No, I don't get an error when I install Roboform add-on. Yes, RF is installed and appears on the Add-on page.

Helpful?

more options

Okay, so the issue now is that Roboform isn't actually available to use. Is there an icon for the extension on the toolbar that indicates it is having a problem connecting to the main program on your system? If the icon is missing, here are three things to check:

(1) Did it slide into the overflow menu -- look for a button similar to >> near the right end of the main toolbar

(2) Is it available in the Customize box -- see Customize Firefox controls, buttons and toolbars

(3) Is it missing because it's not allowed in private windows

This can occur when users switch from recording history normally to automatic private browsing mode (AKA "Never remember history"). Can you recall making a change like that recently?

This is relevant because extensions do not run in private windows unless you specifically enable them for that.

To check, try giving Roboform permission and see whether it shows up on the bar. Here's how.

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

Next to the title of each extension you may find one or more icons (such as the trophy indicating Recommended). If the extension does not have a purple circle with a white mask on it, it is not currently allowed to run in private windows. To change that, click the extension name to show the Details panel, Then scroll down to the section where you can grant permission to run in private windows.

Was that it?

If you didn't intend to change to automatic private browsing, we'll have other suggestions on that.

Helpful?

more options

You can also check the Browser Console for Roboform related message.

Helpful?

more options

Hi, thanks so much for your time and effort in trying to help. RF is available to run on private pages. And yes I see the RF icon on public or private pages. However, it does NOT appear in the Customize list of items. Should it? My other add-ons don't appear there. And, no, the RF icon isn't "hiding" under some other part of the toolbar. Steve

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.