Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Zoom Meetings silently don't open

  • 4 uphendule
  • 1 inale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu pianohacker

more options

When I click on any Zoom link in Firefox 83 on Linux, nothing happens. It seems like Firefox has no idea that the zoommtg:// protocol exists.

I've tried:

  • checking that Firefox is not installed from a snap
  • manually setting the network.protocol-handler.expose.zoommtg and network.protocol-handler.external.zoommtg preferences to true
  • running xdg-open 'zoommtg://...' in a terminal (this works fine, it's how I finished the Zoom SSO login)

Isisombululo esikhethiwe

I _really_ don't understand how this broke, but this fixed my problem:

$ xdg-mime default Zoom.desktop x-scheme-handler/zoommtg

Thank you for your attention regardless :)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Could you check whether any action is saved for zoommtg in the Applications list (on the Preferences page) and, if so, change it to Always Ask. More info in this article: Change what Firefox does when you click on or download a file.

Edit: Adding a screenshot for context:

Okulungisiwe ngu jscher2000

Helpful?

more options

Weirdly, zoommtg doesn't show up in that list:

Helpful?

more options

Hmm, I understand where Firefox finds the protocol handlers for external apps on Window (the Registry) but I don't know where it looks on Linux. When I try to search for Linux advice, the rabbit hole is too deep for me...

Helpful?

more options

Isisombululo Esikhethiwe

I _really_ don't understand how this broke, but this fixed my problem:

$ xdg-mime default Zoom.desktop x-scheme-handler/zoommtg

Thank you for your attention regardless :)

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.