Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Search with ctrl-k no longer works when keyword.enabled = false

  • 1 baphendule
  • 1 inale nkinga
  • 26 views
  • Igcine ukuphendulwa ngu Mike Kaply

more options

For quite some time now I've had keyword.enabled set to false in my about:config because I don't like having the address bar try to autocomplete or turn things into search, when I do a ctrl-l.

I do like that I am still able to use ctrl-k to do a search when I need to. This would place a ? at the start of the field and whatever I type gets sent to search.

In a recent upgrade, ctrl-k still places the ? at the start of the address bar but doesn't send things to search. Instead, it now behaves as if I did a ctrl-l and typed in a bad URL.

I'm on Firefox 80 (on Fedora 32) but I can't be exactly sure which upgrade brought this change in behavior.

Is there a way to get the old behavior back? ctrl-l to enter a URL, ctrl-k to search.

For quite some time now I've had '''keyword.enabled''' set to '''false''' in my '''about:config''' because I don't like having the address bar try to autocomplete or turn things into search, when I do a '''ctrl-l'''. I do like that I am still able to use '''ctrl-k''' to do a search when I need to. This would place a '''?''' at the start of the field and whatever I type gets sent to search. In a recent upgrade, '''ctrl-k''' still places the '''?''' at the start of the address bar but doesn't send things to search. Instead, it now behaves as if I did a '''ctrl-l''' and typed in a bad URL. I'm on Firefox 80 (on Fedora 32) but I can't be exactly sure which upgrade brought this change in behavior. Is there a way to get the old behavior back? '''ctrl-l''' to enter a URL, '''ctrl-k''' to search.

Okulungisiwe ngu Ed

All Replies (1)

more options

I just checked this and it works in the latest Firefox with keyword.enabled false.

Ctrl+K does a search, crl+L does a URL.

Is it working for you now?