Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox and Prime video error "Your Device is connected to the internet using a VPN or proxy service"

  • 2 uphendule
  • 1 inale nkinga
  • 205 views
  • Igcine ukuphendulwa ngu nylans

more options

Hi,

I am getting the above error currently when I try to access amazon Prime Video using Firefox. I have loaded Firefox with all addons disabled and still get the error. I do have a VPN but was not connected to it at the time.

I can also access Amazon Prime at the same time as I am getting the error in Firefox with Microsoft Edge and Chrome with no issues.

Hi, I am getting the above error currently when I try to access amazon Prime Video using Firefox. I have loaded Firefox with all addons disabled and still get the error. I do have a VPN but was not connected to it at the time. I can also access Amazon Prime at the same time as I am getting the error in Firefox with Microsoft Edge and Chrome with no issues.

Isisombululo esikhethiwe

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Isisombululo Esikhethiwe

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

Interesting that this issue suddenly occurred. Anyway it was defaulted to using a proxy for some reason. After I finally found where to change the setting, setting it to No Proxy fixed the issue.

Sort of funny that I did turn on my VPN and was able to access Amazon Prime 

without an error. So guess they are good at detecting the Proxy setting but not so good at detecting VPNs.

Okulungisiwe ngu nylans