Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

javascript not enabled in firefox all of a sudden

  • 3 uphendule
  • 1 inale nkinga
  • 8 views
  • Igcine ukuphendulwa ngu cor-el

more options

I have the following message on my Gmail (using Firefox browswer): JavaScript must be enabled in order for you to use UW Mail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then try again.

Can someone tell me what it is I need to do?

Thank you!

All Replies (3)

more options

Hi llittle, most sites use JavaScript, so if it was completely disabled, you would see messages like that everywhere. It's more likely that a content blocker is affecting the page.

Could you double-check:

Firefox's Enhanced Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

- - - -

Now... anything like that should work with Gmail, so perhaps there is a different issue. Have you gotten any errors about (in)secure connections lately?

Helpful?

more options

NO, I haven't gotten any errors about insecure connections.

I turned off enhanced tracking for the gmail site, but the error message is still there.

JavaScript must be enabled in order for you to use UW Mail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then try again.


.

Helpful?

more options

Do you have any content blocking extensions ?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.